• AVR Freaks

Hot!Bug Report: LoRa Development Utility Crashes with dropdown menu.

Author
Kevin C.
New Member
  • Total Posts : 23
  • Reward points : 0
  • Joined: 2011/09/01 10:29:46
  • Location: 0
  • Status: offline
2017/02/14 13:16:06 (permalink)
0

Bug Report: LoRa Development Utility Crashes with dropdown menu.

When working through the test setup described in the LoRa® Technology Evaluation Suite User’s Guide to configure the DV164140-2 LoRA Evaluation Kit-900 and running the LoRaDevUtility.jar crashes occur when trying to select drop down options during configuration. The two menus I've encountered the problem with so far are the Data Rate selection for the RN module and the Select Database Tableview dropdown menu under Server devices. See attached pictures.
 
Running Windows 10 Pro 64 bit, Java 8 update 121, Docker v1.13.1 (10072) 94675c5,
LoRa Development Utility v 1.0.1. Happy to pull any other needed information.
 
 
post edited by Kevin C. - 2017/02/14 13:21:18

Attached Image(s)

#1

3 Replies Related Threads

    Nikolay_Po
    Super Member
    • Total Posts : 1941
    • Reward points : 0
    • Joined: 2012/04/01 13:49:27
    • Location: Russia, Novorossiysk
    • Status: offline
    Re: Bug Report: LoRa Development Utility Crashes with dropdown menu. 2017/02/15 05:11:40 (permalink)
    3 (1)
    First of all you need to file the "case" for Microchip tech support.
    Ideally, you need to attach a log or at least an error message to bug report. This is for Oracle Java itself but may be useful: Collect Data for a Bug Report. See "A Fatal Error Log" part. IMHO you need to run the utility with command line option to collect the log into dedicated file which may help the utility developers to fix the bug.
    #2
    Kevin C.
    New Member
    • Total Posts : 23
    • Reward points : 0
    • Joined: 2011/09/01 10:29:46
    • Location: 0
    • Status: offline
    Re: Bug Report: LoRa Development Utility Crashes with dropdown menu. 2017/02/21 11:48:37 (permalink)
    3 (1)
    Thanks for the help Nikolay. I've posted some bug issues on the forums before and had some response from the team members of the code set I had issues with, hence my post here. I've since posted over to the support site you linked to and I'm awaiting a response.
    #3
    malfonso0
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2020/12/05 09:16:26
    • Location: 0
    • Status: offline
    Re: Bug Report: LoRa Development Utility Crashes with dropdown menu. 2020/12/14 09:50:01 (permalink)
    0
    hi kevin.
    im starting with the same kit.. and i cant even get connection to mote or gateway.
    do you have any word of advice to me?
    thanks
    #4
    Jump to:
    © 2021 APG vNext Commercial Version 4.5