• AVR Freaks

Hot!No rule to make target

Author
atb
Starting Member
  • Total Posts : 78
  • Reward points : 0
  • Joined: 2003/11/07 12:44:29
  • Location: Pretoria, South Africa
  • Status: offline
2015/09/16 03:49:54 (permalink)
0

No rule to make target

Greetings.
 
I am experiencing a "no rule to make target" problem (seemingly a fairly common problem?) , with a reported error as follows:
 
make[2]: *** No rule to make target '../../../../../Program Files
\(x86\)/Microchip/xc8/v1.20/sources/pic18/plib/XLCD/openxlcd.c', needed by
'build/default/production/_ext/1834950957
 
I am attempting to use the XLCD routines (plib, source file) in XC8 ver 1.20. I have modified the xlcd.h file and therefore need to re-compile the C routines. I have included the routines under the project source files and tried to compile firstly the entire project and subsequently the source files individually. Both efforts lead to the above fault. Compiling the programme without  including the LCD subroutines works fine but then is obviously not tailored to my hardware implementation.
 
My environment is:
 
     Windows 7 Professional
     MPLABX ver 3.05
     XC8  ver 1.20
 
I have tried the following:
 
     Checked the correct tool location (MPLABX: tools/options/embedded/toolchain
     Checked for the correct compiler under project properties
     Re-installed XC8
     Re-installed MPLABX.
     Performed a clean and make.
 
I have successfully compiled the same source code on my home computer with seemingly no significant differences in environment.
 
Any help will be most appreciated.

Regards,
Alan
 
#1

11 Replies Related Threads

    kgyuri
    Starting Member
    • Total Posts : 43
    • Reward points : 0
    • Joined: 2011/12/17 05:16:04
    • Location: Hungary
    • Status: offline
    Re: No rule to make target 2015/09/16 04:35:51 (permalink)
    +1 (1)
    This tipically happens, when the toolchain in the project differs from the installed and default toolchain.
    Check the default setting in the Tools / Options / Embedded / Build tools page, in the Toolchain.
     If differs, delect the appropriate item, and press "Default".
    #2
    atb
    Starting Member
    • Total Posts : 78
    • Reward points : 0
    • Joined: 2003/11/07 12:44:29
    • Location: Pretoria, South Africa
    • Status: offline
    Re: No rule to make target 2015/09/16 04:46:27 (permalink)
    0
    Thanks kgyuri.
     
    The correct tool (XC8 v1.20) had been selected as the default.
    I also tried using another version of XC8 without success.

    Regards,
    Alan
     
    #3
    atb
    Starting Member
    • Total Posts : 78
    • Reward points : 0
    • Joined: 2003/11/07 12:44:29
    • Location: Pretoria, South Africa
    • Status: offline
    Re: No rule to make target 2015/09/16 04:46:27 (permalink)
    0
    Thanks kgyuri.
     
    The correct tool (XC8 v1.20) had been selected as the default.
    I also tried using another version of XC8 without success.

    Regards,
    Alan
     
    #4
    TJ2015
    The New Math
    • Total Posts : 491
    • Reward points : 0
    • Joined: 2015/04/19 11:38:37
    • Location: OSI
    • Status: offline
    Re: No rule to make target 2015/09/16 05:01:55 (permalink)
    +1 (1)
    XC8 v1.20 is quite old, is there any reason you are not using v1.35?
     
    The path for openxlcd.c does not look right.
    on my machine it looks like this "C:\Program Files (x86)\Microchip\xc8\v1.34\sources\pic18\plib\XLCD"
     
    How are you including openxlcd.c in your project?
     
    #5
    atb
    Starting Member
    • Total Posts : 78
    • Reward points : 0
    • Joined: 2003/11/07 12:44:29
    • Location: Pretoria, South Africa
    • Status: offline
    Re: No rule to make target 2015/09/16 05:32:47 (permalink)
    0
    Thanks TJ2015.
     
    I had installed XC8 v1.35 but found that it did not include the plib library (!?). I copied it from v1.20 and encountered the fault. I then went back to the unmodified v1.20 in case I had made an error with the file copying.
     
    I am including openxlcd.c as a sourcefile in the project.
     
    openxlcd.c resides in the same location as indicated by yourself with the obvious exception of v1.20.
     
    Regards,
    Alan
    #6
    DarioG
    Allmächtig.
    • Total Posts : 54081
    • Reward points : 0
    • Joined: 2006/02/25 08:58:22
    • Location: Oesterreich
    • Status: offline
    Re: No rule to make target 2015/09/16 05:38:41 (permalink)
    0
    Yeah, PLIB now has been moved to a separate download.

    GENOVA :D :D ! GODO
    #7
    TJ2015
    The New Math
    • Total Posts : 491
    • Reward points : 0
    • Joined: 2015/04/19 11:38:37
    • Location: OSI
    • Status: offline
    Re: No rule to make target 2015/09/16 05:56:37 (permalink)
    +1 (1)
    DarioG
    Yeah, PLIB now has been moved to a separate download.


    You can find this on the same page where you download XC8
     
     
    Try removing openxlcd.c from your project and set this linker option
    Attachments are not available: Download requirements not met  

    Attachment(s)

    Attachments are not available: Download requirements not met
    #8
    atb
    Starting Member
    • Total Posts : 78
    • Reward points : 0
    • Joined: 2003/11/07 12:44:29
    • Location: Pretoria, South Africa
    • Status: offline
    Re: No rule to make target 2015/09/16 07:02:53 (permalink)
    +1 (1)
    Thanks for the inputs all.
    Problem now resolved although not yet fully understood.
     
    TJ2015, you were onto something with your first reply regarding the path which did not look correct. Although the path appears to be correct when viewed with Windows Explorer, the path reported by MPLABX was strange. I copied the XLCD files to another location and compilation is now successful.
     
    I will now try to slowly reverse my efforts in order to try and understand what happened.
     
    Many thanks to all.
    Alan
    #9
    tporter905
    Junior Member
    • Total Posts : 42
    • Reward points : 0
    • Joined: 2010/12/06 14:13:54
    • Location: 0
    • Status: offline
    Re: No rule to make target 2015/10/20 10:47:33 (permalink)
    +1 (1)
    I see this problem is resolved, however was going crazy trying to figure out why a driver file provided by a vendor for the MLA would give this error. All the other files in my project compiled fine, just the one from the vendor. I eventually figured it out, the provided files had a capital H and capital C extension! When I renamed the files to have a lower case h and lower case c extension, all worked fine! Drove me crazy trying to figure it out, so I decided to post this just in case anyone else has this issue.
     
    Thanks,
     
    Tom
    #10
    AndersG
    Super Member
    • Total Posts : 225
    • Reward points : 0
    • Joined: 2008/08/05 04:51:24
    • Location: 0
    • Status: offline
    Re: No rule to make target 2020/09/22 11:09:52 (permalink)
    +1 (1)
    It can also happen when you hade the incorrect "pack" selected.
    #11
    seyyah
    Super Member
    • Total Posts : 640
    • Reward points : 0
    • Joined: 2004/05/14 12:49:28
    • Status: offline
    Re: No rule to make target 2020/10/04 03:59:00 (permalink)
    +1 (1)
    I have a similar problem but it happens when I started MCC. I think its mplabx and windows permissions related thing. I could not solve it and I am forced to restart mplabx in order to solve the problem each time. Are there any ideas?
    #12
    Jump to:
    © 2020 APG vNext Commercial Version 4.5