• AVR Freaks

Generated SQTP wrong with IPE 2.10, ICD3 if #bytes > 8

Author
BradLevy
Starting Member
  • Total Posts : 44
  • Reward points : 0
  • Joined: 2007/10/23 15:21:30
  • Location: Kansas
  • Status: offline
2014/06/18 02:14:45 (permalink)
0

Generated SQTP wrong with IPE 2.10, ICD3 if #bytes > 8

I tried generating a sequence of 10 byte serial numbers using IPE 2.10 with the ICD3, for PIC12HV752.
(I wanted long numbers so I could embed production date info.)
I found that the IPE-generated .num file contained the wrong sequence. The data was correct for the first chip, but the sequence reset to 1, 2, 3... for the second, third, fourth chip, etc. The upper bytes of the data were all reset to zero after the first chip.

I did some experimenting, and found that the IPE appears to generates the correct sequence if the number of bytes is 8 (16 hex digits) or less, but generates the incorrect sequence after the first chip if the number of bytes is 9 or more.
If you set the number of bytes to 15 or more, you get an error message when you try to generate the sequence, informing you that the number of bytes cannot be larger than 14. So evidently the program was intended to work for up to 14 bytes, but didn't use buffers big enough to hold data that long.

(I posted some about this as a reply to an earlier post of mine on a different topic, because the forum software was giving me error messages when I tried to post it as a new message. This new post adds new details I discovered since then, and having a relevant title instead of being tacked on another post, should be more useful to others searching regarding this SQTP issue.)
-Brad
post edited by BradLevy - 2014/06/18 20:32:57
#1
Sudheer Herle
Super Member
  • Total Posts : 413
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re: Generated SQTP wrong with IPE 2.10, ICD3 if #bytes > 8 2014/06/19 21:33:33 (permalink)
0
Hi Brad,
 
I could reproduce the issue. Only the first line of the SQTP contains your actual data.
If it helps you, MPLAB8 IDE generates the correct SQTP file. May be Microchip will fix this by next release in MPLABX.
 
Thanks,
Sudheer
#2
Jump to:
© 2019 APG vNext Commercial Version 4.5