LockedMPLABXC8.dll Post Install Error

Author
pcfr33k
New Member
  • Total Posts : 24
  • Reward points : 0
  • Joined: 2011/09/16 12:24:25
  • Location: 0
  • Status: offline
2012/10/19 16:17:13 (permalink)
0

MPLABXC8.dll Post Install Error

I tired more than once to get this to install on windows 7 32 bit.  Cleanly installed windows.  No Anti-Virus Running. 
  
All other compilers installed fine.  The XC 16,18 and 32 compilers installed fine .  Just a problem with this XC 8!! 
  
It actually did complete the install I just got the error. 
  
See jpg file attached 
post edited by pcfr33k - 2012/10/19 17:01:25

Attached Image(s)

#1

19 Replies Related Threads

    NKurzman
    A Guy on the Net
    • Total Posts : 17002
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: online
    Re:MPLABXC8.dll Post Install Error 2012/10/19 18:53:33 (permalink)
    0
    Did you try installing in XP compatibility mode?
    I have read there are some issues if your permissions are not correct.
    #2
    pcfr33k
    New Member
    • Total Posts : 24
    • Reward points : 0
    • Joined: 2011/09/16 12:24:25
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2012/10/19 19:26:25 (permalink)
    0
    It won't even start the install with XP compatibility mode.  Its telling me there is no Documents and Settings/application folder.
     
    WHen I try to create one windows 7 says it already exist.  I don't see one from the C drive.
    Windows Vista Compatibility mode same error message as windows 7.

    Anyhow that doesn't work.  There is something wrong with the XC8 installer plain and clear!!!!
     
    #3
    NKurzman
    A Guy on the Net
    • Total Posts : 17002
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: online
    Re:MPLABXC8.dll Post Install Error 2012/10/19 20:57:05 (permalink)
    0
    You can put in a Microchip Support Ticket.
     
    Note: in Win 7 Documents and Settings is not a real folder it is a "Junction" to the new equivalent Win 7 folder.
    #4
    bluejets
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2012/12/30 00:21:14
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2012/12/30 00:25:41 (permalink)
    0
    I use Win XP sp3 and get exactly the same error message.
     
    Has anyone fixed this yet or suggest where the problem lies.
     
    Thanks.......................... 
    #5
    fregat
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2012/12/30 15:42:02
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2012/12/30 15:49:08 (permalink)
    0
    The same problem. I am using W7 32bit ultimate edition.
    What does it mean? What is to do?
    Please help asap.
     
    Bests.
    #6
    xiaofan
    Super Member
    • Total Posts : 6247
    • Reward points : 0
    • Joined: 2005/04/14 07:05:25
    • Location: Singapore
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2012/12/30 16:41:41 (permalink)
    0
    I have the same problem under Windows 8 Pro x64. On the other hand, the compiler seems to still work.
     
    If you manually register the dll (run cmd as admin and then cd to the directory and then run regsvr32), you will get to know a bit more about the error.
    Error from RegSvr32:
    "The module "MPLABXC8.dll" failed to load.
     
    Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.
     
    The specified modules could not be found."
     
    I think a support ticket is the way to go in this case.

      USB_Links and libusb
    #7
    bluejets
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2012/12/30 00:21:14
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2012/12/30 17:51:45 (permalink)
    0
    Uninstalled Mplab and xc8 compiler.
    Went to programs folder and deleted "microchip" folder and contents.
    Went to registry and tried to delete microchip there but not allowed.
    Went to the archives ...
    http://www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId=1406&dDocName=en023073
    Downloaded and installed MplabX v1.10 and xc8 v1.00.
    All installed ok without any errors.
    #8
    bluejets
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2012/12/30 00:21:14
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/04 16:28:12 (permalink)
    0
    So how do we start this so-called support ticket. How do we do this. Need some answers to fix this.
    #9
    SHidem
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2013/01/22 13:48:07
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/22 13:58:39 (permalink)
    0
    I ran dependency walker against the DLL and found I was missing "msvcr71.dll" and "msvcp71.dll". I located copies of these files (x86 in my case) and copied them into the same directory as the offending DLL. Then the DLL will register.
    BTW, don't bother installing the redistributable package from Microsoft. It won't solve the problem. Put the msvc*71 files in the directory as indicated above.
     
    Good luck,
    Steve
    #10
    bluejets
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2012/12/30 00:21:14
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/23 02:30:47 (permalink)
    0
    So where did you find these files..??
    Many places I look advise not to get them from places other than original program supplier.
    #11
    SHidem
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2013/01/22 13:48:07
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/23 10:26:01 (permalink)
    0
    Hi Blujets,
    I've been writing embedded code and Windows apps for many years now and have a number of version of Visual Studio. I got the msvc DLLs from the redistributables on my PC. You are prudent not to trust other suppliers, but in this case Microsoft did not digitally sign these DLLs, which is kinda surprising. Run a virus scanner against the DLLs first, then copy them to XC8/bin directory. I've attached a zip of the files.
     
    The real problem is the people who did the installer did not scan for dependencies and include the dependent items in the installer. I'm going to submit a bug report to Microchip about the installer.
     
    Cheers,
    Steve
    #12
    bluejets
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2012/12/30 00:21:14
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/24 02:26:36 (permalink)
    0
    Thanks Steve, appreciate it.
    I have a ticket there and initially they claimed that it had been fixed in the latest version and suggested that I download and install that, however it still came up with the same error.
     
    So the present ticket they are still chewing over with no word back yet.
     
    #13
    bluejets
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2012/12/30 00:21:14
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/25 16:29:33 (permalink)
    0
    Seems odd the reply I received on the ticket I posted to Microchip.
    After all, we are still waiting for a fix from them for this error.
    Lucky we have others here that seem to be more interested in supplying a fix.
     
    Quote ..........
    [font="'times new roman', serif"]Ticket is being moved to Resolved Status, due to inactivity. This system will move the ticket to “Closed” status after 10 days. Up until that point you may still return and add further activity to this ticket. After that point you will have to open a new ticket.
    [font="'times new roman', serif"]Thanks and Regards 
    [font="'times new roman', serif"]Tilak
    [font="'times new roman', serif"]Compiler Analysis and Assistance Team
    #14
    Franzarn
    New Member
    • Total Posts : 26
    • Reward points : 0
    • Joined: 2012/08/18 01:42:56
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/26 03:25:48 (permalink)
    0
    Hello,
    I have exactly the same installation problem on a brand new Windows 7 32 bit platform.
    It seems strange that Microchip doesn't correct a so visible bug and doesn't read this forum !!
    FZ
    #15
    Jorgen
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2013/01/26 04:15:29
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/26 04:30:27 (permalink)
    0
    I got the same error and ignored it. Is that the right way to deal with it?
    #16
    SHidem
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2013/01/22 13:48:07
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/28 12:26:58 (permalink)
    0
    Hi Jorgen,
    I wouldn't ignore it. I'm just guessing but the DLL is probably registering ActiveX components or something so the compiler works with other parts of the IDE. Grab the MS VC runtimes I've attached in a previous post and copy them into the directory that has the DLL.
     
    Cheers,
    Steve
    #17
    Jorgen
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2013/01/26 04:15:29
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2013/01/28 13:11:29 (permalink)
    0
    Hi Steve,
     
    Well, I have registered the MPLABXC8.dll following the procedure described by you. It worked. Thanks a lot.
    I really hope Microchip will soon come with an update to XC8 with this bug fixed and with the migration document promised some months ago.
     
    Regards,
     
    Jorgen
     
     
     
     
    #18
    nekodar
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2014/08/16 01:20:10
    • Location: 0
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2014/08/16 01:24:07 (permalink)
    0
    Will Microchip EVER get around to fix this?
    Just tried to install XC8 1.32 on Windows 8 64bit and got the same error.
     
    Judging by the OP, this has been a known problem for almost 2 years, possibly more, and nothing's been done about it yet....
    #19
    ric
    Super Member
    • Total Posts : 22101
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re:MPLABXC8.dll Post Install Error 2014/08/17 19:50:46 (permalink)
    0
    That's a bit slack of Microchip.
    I guess most if their users, and all of their Beta testers, already have Visual Studio installed on their PCs, so they already had the necessary files.
    You could probably just install the free "Visual Studio Express" to get them.
    http://www.microsoft.com/.../details.aspx?id=40787

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #20
    Jump to:
    © 2019 APG vNext Commercial Version 4.5