• AVR Freaks

Helpful ReplyHot!Pickit 3 MPLABX and IPE Connection Failed

Author
Leonimer
Starting Member
  • Total Posts : 33
  • Reward points : 0
  • Joined: 2009/07/18 04:23:41
  • Location: 0
  • Status: offline
2012/08/15 14:00:28 (permalink)
0

Pickit 3 MPLABX and IPE Connection Failed

I cannot connect de IPE and/or MPLAB with my Pickit 3 programmer. With MPLAB 8.6 it works perfectly. What could be the problem?
 
Thanks,
Leonimer
#1
Sudheer Herle
Super Member
  • Total Posts : 410
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/15 21:14:14 (permalink)
0
Hello Leonimer,
 
Can you please share the error message you are getting when you connect PICkit3 in IPE?
Thanks,
Sudheer
#2
Leonimer
Starting Member
  • Total Posts : 33
  • Reward points : 0
  • Joined: 2009/07/18 04:23:41
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/16 05:20:18 (permalink)
0
This is the error message:
*****************************************************
Connection Failed.

 




 
#3
Sudheer Herle
Super Member
  • Total Posts : 410
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/16 06:05:58 (permalink)
0
I never came across this. What is the device you have selected?
And are you sure, you are not running MPLAB8 along side with programmer tool selected as PICkit3  in it?
#4
Leonimer
Starting Member
  • Total Posts : 33
  • Reward points : 0
  • Joined: 2009/07/18 04:23:41
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/16 06:43:36 (permalink)
0
Sudheer Herle

Hello Leonimer,

Can you please share the error message you are getting when you connect PICkit3 in IPE?
Thanks,
Sudheer

 
Message error from MPLABX:
Connecting to programmer...
The programmer could not be started: Could not connect to tool hardware: PICkit3PlatformTool, com.microchip.mplab.mdbcore.PICKit3Tool.PICkit3DbgToolManager
and:
*****************************************************
Connection Failed.


*****************************************************

Connecting to MPLAB PICkit 3...
Connection Failed.
------------------------------------------------------------------
My About MPLABX:

Product Version: MPLAB X IDE v1.30
Java: 1.6.0_32; Java HotSpot(TM) 64-Bit Server VM 20.7-b02
System: Windows 7 version 6.1 running on amd64; Cp1252; pt_BR (mplab)
Userdir: C:\Users\Joaquim\AppData\Roaming\.mplab_ide\dev\v1.30

#5
Leonimer
Starting Member
  • Total Posts : 33
  • Reward points : 0
  • Joined: 2009/07/18 04:23:41
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/16 06:51:11 (permalink)
0
Sudheer Herle

I never came across this. What is the device you have selected?
And are you sure, you are not running MPLAB8 along side with programmer tool selected as PICkit3  in it?

I'm quite sure that I am NOT using MPLAB 8 with MPLABX.

#6
Sudheer Herle
Super Member
  • Total Posts : 410
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/16 22:17:03 (permalink)
0
You might be using a device which is not supported. Do you see RED light against the tool in IDE or IPE?
#7
Dirk_G
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2012/08/29 23:55:04
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/30 00:39:07 (permalink)
0
Hello together,
I have also the problem of getting no connection with MPLAB X and PICkit 3 and I have no solution.
Versions and computer:

Product Version: MPLAB X IDE v1.30
Java: 1.6.0_32; Java HotSpot(TM) 64-Bit Server VM 20.7-b02
System: Windows 7 version 6.1 running on amd64; Cp1252; de_DE (mplab)
My PICkit 3 has the Serial No. BUR121082339
The target is powered, and there are no forbidden components connected to the MCLR, ICSPDAT, and -CLK lines.
I'm running MPLAB X as administrator and have no other MPLAB version on my computer (and have not had before).
The project settings show green status for both the PICkit and the Device PIC16F1824.
The project for an PIC16F1824 was built successfully, but when trying to debug or program the device, in the PICkit output window I get the message
 
Connecting to MPLAB PICkit 3...
Connection Failed.
 
and in the Debugger Console resp. in the project (Build, Load,... ) output window I get the message
 
Could not connect to tool hardware: PICkit3PlatformTool, com.microchip.mplab.mdbcore.PICKit3Tool.PICkit3DbgToolManager
 
- Is maybe a too old firmware in the PICkit 3 the issue (it was shipped together with MPLAB v8.70 on CD)?
- Is a PICkit firmware upgrade possible without another programmer (we have one PICkit only so far because of migrating with the project from another microcontroller vendor)
- Does it make sense to install the MPLAB v8.70?
    - What about the USB drivers then?
    - Has the MPLAB X to be unistalled before installing v8.70?
 
Thank you very much for your help.
 

#8
Sudheer Herle
Super Member
  • Total Posts : 410
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/30 11:05:06 (permalink)
0
Hello Dirk,
 
You can install MPLAB8 and MPLABX on same machine. But make sure you switch the drivers using the driver switcher software (required for ICD3, Real ICE, PM3). You don't have to worry about the drivers for PICKit3!
 
- Firmware is not too old on MPLAB 8.70
 
- In MPLABX, select auto firmware download under project properties-> PICkit3. Your PICKit3 will be automatically upgraded to latest firmware that came with MPLABX IDE.
 
Thanks,
Sudheer
 
#9
Sudheer Herle
Super Member
  • Total Posts : 410
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/30 11:08:55 (permalink)
0
If you are interested in just programming the device, please try with MPLAB IPE. 
 
Thanks,
Sudheer
#10
Dirk_G
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2012/08/29 23:55:04
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/31 01:58:17 (permalink)
5 (1)
Hello Sudheer,
thanks for your hint that there will be no problem of installing two different MPLAB versions and that there is nothing to change with the USB drivers when only the PICkit shall be used.
With your help I've got the connection PICkit 3 to MPLAB X working Smile
I describe the procedure as a step-by-step guide, so I hope that it may help other MPLAB and PICkit users, too:
1. Install MPLAB v8.87 from www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId=1406&dDocName=en019469&part=SW007002  (the before installed MPLAB X does NOT need to be deinstalled).
    After the installation no switching of USB drivers is necessary in case of PICkit use, so DO NOT start the MPLAB driver switcher
2. Start MPLAB 8.87, do NOT create any project, but only choose Menu "Configure" --> Select Device, choose your target device and press <OK>
3. Connect the PICkit 3 via USB to the computer and to the powered target device
3. Choose in MPLAB 8.87 the Menu "Programmer" --> Select Programmer --> PICkit 3
    Now MPLAB 8.87 realizes that the PICkit needs a new firmware and starts automatically an update procedure: Subsequentially it downloads a new bootloader, then a new RS and then a new AP.
    In my case it downloaded the bootloader successfully, but got stuck during the RS download. So, if after one minute the RS download has not completed, please pull off and connect again the USB cable. The MPLAB automatically repeats the RS step then. After success a few seconds later it tries to download the new AP, where - in my case - again it got stuck. Then again USB re-connection leads to succesful update of the AP.
4. Now in MPLAB 8.87 go to "Programmer" --> None; then close MPLAB 8.87
5. Start MPLAB X, open your project and click the "Debug Project" button or the "Make and Program Device" button. The project will be built and the connection to PICkit be established then. For the connection again some new parts of PICkit firmware (in my case again an AP) are automatically downloaded. Then everything should work fine.
 
#11
Dirk_G
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2012/08/29 23:55:04
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/08/31 02:05:29 (permalink)
0
Hello Leonimer,
 
I had the same problem and got a solution by Sudheer's help. I described the necessary procedure a few minutes ago in an answer to Sudheer in the forum.
Maybe the firmware update of the PICkit also works by use of older MPLAB versions than v8.87; so at first you could try it with your MPLAB v8.60.
 
#12
Sudheer Herle
Super Member
  • Total Posts : 410
  • Reward points : 0
  • Joined: 2012/03/30 05:41:29
  • Location: Bangalore ,India
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2012/09/02 21:03:01 (permalink)
0
Hello Dirk, 
 
Your explanation was clear and crisp!. Thanks. But i would like to add that even in MPLABX, PICkit3 gets an automatic firmware update. Only difference compared with MPLAB8 is that in MPLABX, firmware update happens only when you perform any operation like write, read, erase, blank check, verify. 
 
You might have come across this. Still, i considered posting this information as this may help others.
 
Thanks,
Sudheer
#13
MicroSE
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2013/12/04 11:41:32
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2013/12/04 11:56:01 (permalink) ☄ Helpfulby León Felipe Hernández López 2014/07/14 16:52:46
5 (1)
PicKit 3 Communication error with MPLAB X or IPE?
Solution!: 
Step 1: Connect PicKit 3 to PC
Step 2: Open PicKit 3 Programmer App v3.10
Step 3: Go to, Tools>Revert to MPLAB Mode
#14
León Felipe Hernández López
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2014/07/14 16:52:33
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2014/07/14 16:55:45 (permalink) ☄ Helpfulby hwasti 2014/08/10 21:34:59
1 (1)
Also you can do the "Revert to MPLAB Model" by just holding the pickit3 button while is being plugged to the pc.
That works for me 
#15
ERTAN SULUAGAC
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2018/04/05 03:37:19
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2019/03/29 01:17:01 (permalink)
0
MicroSe Thanks;
It was ok.
#16
Regina Chang
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2019/04/15 18:09:52
  • Location: 0
  • Status: offline
Re:Pickit 3 MPLABX and IPE Connection Failed 2019/04/15 19:31:24 (permalink)
0
Pickit 3 cannot connect to PC with MPLABX?
 
#17
Jump to:
© 2019 APG vNext Commercial Version 4.5