• AVR Freaks

Lost PicKit3 when upgrading to OSX 10.8 Mountain Lion

Author
svaha
New Member
  • Total Posts : 15
  • Reward points : 0
  • Joined: 2012/03/06 18:21:38
  • Location: 0
  • Status: offline
2012/08/04 15:31:00 (permalink)
0

Lost PicKit3 when upgrading to OSX 10.8 Mountain Lion

I know it's still working because I can successfully connect to it in Parallels with Windows 7 on the same computer.
 
Everything was working fine before install. Still works fine on virtual machine. 
 
My mplab_ide.conf points to:
jdkhome="/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home"
 
 
My Apple Java preferences are
32-bit Java SE 6, v. 1.6.0_33-b03-424
64-bit Java SE 6, v. 1.6.0_33-b03-424
I changed their preferred order and still no luck.
 
Running system_profiler SPUSBDataType from the command line I get:  
    USB Bus: 
      Host Controller Location: Built-in USB     
      Host Controller Driver: AppleUSBOHCI     
      PCI Device ID: 0x7fdf00000d9c      
      PCI Revision ID: 0x7fdf000000a1      
      PCI Vendor ID: 0x7fdf000010de       Bus Number: 0x04 
      PICkit 3:
          Product ID: 0x900a          Vendor ID: 0x04d8  (Microchip Technology Inc.)         
          Version: 0.02             
          Speed: Up to 12 Mb/sec          Manufacturer: Microchip Technology Inc.         
          Location ID: 0x04100000 / 2          Current Available (mA): 500          Current Required (mA): 500

 
So it's obviously there. 
Any suggestions? 
 
I'll be at the Microchip Master's Conference... Maybe I can troubleshoot this with someone?
 
#1

2 Replies Related Threads

    Guest
    Super Member
    • Total Posts : 80503
    • Reward points : 0
    • Joined: 2003/01/01 00:00:00
    • Location: 0
    • Status: online
    Re:Lost PicKit3 when upgrading to OSX 10.8 Mountain Lion 2012/08/05 04:14:48 (permalink)
    0
    I had the same problem. Reinstalling MPLAB seemed to fix it, not that that's a very elegant solution.
    #2
    svaha
    New Member
    • Total Posts : 15
    • Reward points : 0
    • Joined: 2012/03/06 18:21:38
    • Location: 0
    • Status: offline
    Re:Lost PicKit3 when upgrading to OSX 10.8 Mountain Lion 2012/08/05 21:03:33 (permalink)
    0
    Thanks! That worked for me too.
    #3
    Jump to:
    © 2021 APG vNext Commercial Version 4.5