pic30-lm stopping each compiling with v3.31

Author
phileinstein
Starting Member
  • Total Posts : 47
  • Reward points : 0
  • Joined: 2010/08/11 21:58:32
  • Location: 0
  • Status: offline
2012/01/10 03:40:39 (permalink)
0

pic30-lm stopping each compiling with v3.31

pic30-lm with v3.31 has a bug. When compiling, showing "Microsoft Windows" dialog with "pic30-lm.exe has stopped."
 
And then MPLAB IDE "Build Output" show followings.
 
pic30-coff-cc1.exe: warning: General License error, please install a license
Options have been disabled due to invalid license
Visit http://www.microchip.com/ to purchase a new key.
 

Attached Image(s)

#1

11 Replies Related Threads

    Cashomoto
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2011/10/18 18:58:47
    • Location: 0
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/10 12:11:45 (permalink)
    0
    Having the same problem. This is some sort of licencing error. PIC30-lm is a licencing program. Super lame! Help will be appreciated. I'll post updates as they come. 
    #2
    Cashomoto
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2011/10/18 18:58:47
    • Location: 0
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/10 12:39:40 (permalink)
    0
    Found a solution. Instead of downloading the C30 that is on their link try the older 3.30 version for academic use. If you are a professional maybe this isn't the best solution but it works. Here is a link 

    http://www.microchip.com/stellent/idcplg?IdcService=SS_GET_PAGE&nodeId=1406&dDocName=en536656
    #3
    cawilkie
    Administrator
    • Total Posts : 1977
    • Reward points : 0
    • Joined: 2003/11/07 12:49:11
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/10 14:31:38 (permalink)
    0
    Do you guys have a license?  If not, super lame.

    If so then perhaps someone would be kind enough to translate the picture?  Or open a support ticket with support.microchip.com since they would likely want to know what your license key and operating system is, and clearly you would not want to post that information of a public web-forum.

    Regards
    Calum
    #4
    phileinstein
    Starting Member
    • Total Posts : 47
    • Reward points : 0
    • Joined: 2010/08/11 21:58:32
    • Location: 0
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/10 21:48:43 (permalink)
    0
    I found the workaround. Replace the pic30-lm.exe for v3.30.
    See http://www.microchip.com/forums/m602364.aspx
     
    There is not license problem but illegal pic30-lm.exe stopping on Windows.
     
     
    #5
    tony4l
    Super Member
    • Total Posts : 473
    • Reward points : 0
    • Joined: 2003/11/07 12:36:16
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/27 11:59:38 (permalink)
    0
    confirmed with mplab 8.83 and C30 3.31 on Win7/x64. I only upgraded the compiler, changed nothing else. I'm positive that C30 3.30b/c works fine. pic30-lm simply crashes. Here's the details from the crash dialog: Problem signature: Problem Event Name: APPCRASH Application Name: pic30-lm.exe Application Version: 0.0.0.0 Application Timestamp: 4eaac7c3 Fault Module Name: pic30-lm.exe Fault Module Version: 0.0.0.0 Fault Module Timestamp: 4eaac7c3 Exception Code: c0000005 Exception Offset: 00004725 OS Version: 6.1.7601.2.1.0.256.1 Locale ID: 1033 Additional Information 1: 0a9e Additional Information 2: 0a9e372d3b4ad19135b953a78882e789 Additional Information 3: 0a9e Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    beware of ASCII characters when posting. better safe than sorry!
    #6
    tony4l
    Super Member
    • Total Posts : 473
    • Reward points : 0
    • Joined: 2003/11/07 12:36:16
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/27 12:11:42 (permalink)
    0
    also confirming that overwriting pic30-lm with the executable from 3.30 is a workaround.

    beware of ASCII characters when posting. better safe than sorry!
    #7
    cawilkie
    Administrator
    • Total Posts : 1977
    • Reward points : 0
    • Joined: 2003/11/07 12:49:11
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/30 08:31:58 (permalink)
    +4 (5)
    We had some reports of this in house so was able to attach a scope to it and understand the root cause. 

    Attached is a fix for this issue.  To install, make a backup of <install-dir>/bin/pic30-lm.exe and unzip and install the attached executable.

    Regards
    Calum
    #8
    tony4l
    Super Member
    • Total Posts : 473
    • Reward points : 0
    • Joined: 2003/11/07 12:36:16
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2012/01/31 07:00:09 (permalink)
    0
    fix confirmed. thank you for the quick turnaround.

    beware of ASCII characters when posting. better safe than sorry!
    #9
    bibinpaul
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2013/05/15 19:24:23
    • Location: 0
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2013/05/15 19:30:12 (permalink)
    0
    Fixed the issue, Thanks a lot
    #10
    iz0abd
    New Member
    • Total Posts : 28
    • Reward points : 0
    • Joined: 2008/10/22 02:30:03
    • Location: Italy
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2016/01/08 08:13:01 (permalink)
    0
    Worsk for me too. Thanks

    Audaces fortuna iuvat.
    #11
    fbito
    New Member
    • Total Posts : 1
    • Reward points : 0
    • Joined: 2016/10/17 08:04:03
    • Location: 0
    • Status: offline
    Re:pic30-lm stopping each compiling with v3.31 2016/10/20 01:02:27 (permalink)
    0
    finally fixed this! worked for me as well!:-)
    #12
    Jump to:
    © 2019 APG vNext Commercial Version 4.5