• AVR Freaks

PicKit 3 Connecting Forever

Author
crm7811
Senior Member
  • Total Posts : 152
  • Reward points : 0
  • Joined: 2008/10/22 00:12:10
  • Location: Lafayette, LA
  • Status: offline
2010/10/26 16:01:01 (permalink)
0

PicKit 3 Connecting Forever

I have a PicKit 3 that has been working fine for several months now, but haven't used it in a few weeks.  I recently pulled it out of the drawer, plugged it into the computer, started MPLAB 8.56, and tried to tell it to use the PicKit 3 for a project, but the PicKit 3 just says connecting and will not do anything else.  Is there some way to remedy this problem?  Does anyone know what the problem is?  Thank you for the help in advance.
#1

7 Replies Related Threads

    crm7811
    Senior Member
    • Total Posts : 152
    • Reward points : 0
    • Joined: 2008/10/22 00:12:10
    • Location: Lafayette, LA
    • Status: offline
    Re:PicKit 3 Connecting Forever 2010/10/26 16:04:35 (permalink)
    0
    Fixed the problem by switching the USB port I was  using for the PicKit 3 programmer.      
    #2
    crm7811
    Senior Member
    • Total Posts : 152
    • Reward points : 0
    • Joined: 2008/10/22 00:12:10
    • Location: Lafayette, LA
    • Status: offline
    Re:PicKit 3 Connecting Forever 2010/10/26 16:08:07 (permalink)
    0
    Nevermind.  The problem came back once again.  I don't know what is up with it as I have tried restarting the computer as well and restarting the computer didn't help.
    #3
    errN0P
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2010/10/27 01:44:51
    • Location: 0
    • Status: offline
    Re:PicKit 3 Connecting Forever 2010/10/27 01:49:08 (permalink)
    0
    Hi
    I am have this exact same problem with MPLAB 8.46
    PICkit3 just purchased today and staus led is constantly yellow.
    MPLAB recognises PK3 is connected but just sits there connecting.
    #4
    errN0P
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2010/10/27 01:44:51
    • Location: 0
    • Status: offline
    Re:PicKit 3 Connecting Forever 2010/10/27 02:47:50 (permalink)
    0
    errN0P

    Hi
    I am have this exact same problem with MPLAB 8.46
    PICkit3 just purchased today and staus led is constantly yellow.
    MPLAB recognises PK3 is connected but just sits there connecting.


    Worked in another PC
    Problem temporarily solved by using an unpowered hub in the origingal PC - a workaround, yes, but really, must I?.
     
    C'mon Microchip - what gives? - does not bode well for USB support in devices does it if you can't even support it well in you own programmer/debugger?
    #5
    crm7811
    Senior Member
    • Total Posts : 152
    • Reward points : 0
    • Joined: 2008/10/22 00:12:10
    • Location: Lafayette, LA
    • Status: offline
    Re:PicKit 3 Connecting Forever 2010/10/27 06:10:11 (permalink)
    0
    Please don't knock Microchip in this thread.  If you have a problem with them then please don't hijack my thread where I am trying to get some help with a problem.
    #6
    errN0P
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2010/10/27 01:44:51
    • Location: 0
    • Status: offline
    Re:PicKit 3 Connecting Forever 2010/10/27 14:18:39 (permalink)
    0
    crm7811

    Please don't knock Microchip in this thread.  If you have a problem with them then please don't hijack my thread where I am trying to get some help with a problem.


    Don't take this the wrong way ... but ...

    1. Its an open forum so folks like me are going to say things *you* don't like. Deal with it. You got at least 1 possible solution now.

    2. Microchip can speak for themselves they are big boys (and girls) -> http://www.eevblog.com/20...ammerdebugger-review/. At the end of the day a little noise from the squeaky wheel fixes the whole machine.

    3. Now they (Microchip) know they have an issue that has a workaround (if it hasn't already been logged). If they have used their own USB stack in this project then it can be looked at to find out what it going on. This is not an isolated issue. Look around the forum, it may have wider implications.


    #7
    errN0P
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2010/10/27 01:44:51
    • Location: 0
    • Status: offline
    Re:PicKit 3 Connecting Forever 2010/10/28 23:32:55 (permalink)
    0
    Problem solved.
    MPLAB V8.60 has a new firmware update for the PICkit3
    #8
    Jump to:
    © 2019 APG vNext Commercial Version 4.5