Firmware for Explorer 16, 18F4550 (U2) (unofficial)

Page: < 12345 Showing page 5 of 5
Author
SohlMan
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2011/03/23 05:27:18
  • Location: 0
  • Status: offline
RE: Firmware for Explorer 16, 18F4550 (U2) (unofficial) 2011/03/23 05:30:39 (permalink)
0
polyscient

Thank you! The link you have in post #80 got me functioning in minutes. 
#81
ajs410
Junior Member
  • Total Posts : 97
  • Reward points : 0
  • Joined: 2011/05/19 13:08:46
  • Location: 0
  • Status: offline
RE: Firmware for Explorer 16, 18F4550 (U2) (unofficial) 2011/05/19 13:17:21 (permalink)
0
I have an Explorer16 and the PIC24FJ256B110 PIM.  I have used rafalw's modified 4550 code to make it look like a PICkit 2.  FirmwareV2.100.07b.for.Explorer16

I am able to successfully program the PIM.  After the firmware is programmed, I have to press "run" and that works okay.

However, I am unable to use the debugger features; if I press "Halt" then MPLAB stops responding.  If I hit a breakpoint, the PIM's firmware stops execution but MPLAB doesn't show the breakpoint as being hit.  Once either of these conditions occur, if I unplug the USB and plug it back in again, I get Unknown Hardware, which means that the 4550 isn't responding to enumeration requests.

EDIT:

I think I may have narrowed the problem down.  One potential issue is that the demo application I was using (Joystick) was setting RA0 and RA1 as outputs.  However, these are connected to the 4550's TMS and TCK pins.  I was afraid of potential contention on these lines, so I set them as inputs.  This did not seem to solve the problem, however it does seem like the intelligent thing to do, so I left that part in.

This next method has managed to solve the problem I was having.

1) Build
2) Program
3) RESET! (this is the important part!)
4) Run

Now I can use debugger features normally.

EDIT2:

It stopped working again.  sad

I don't understand.  I had this working yesterday.

I can Animate.  I can Step.  I can Run to Cursor, as long as it doesn't take long for execution go get there.  But if I Run, MPLAB locks up after about one second.

I have tried MPLAB 8.53 and 8.31.

EDIT3:

Ended up purchasing a PICkit 3.  No problems now.  on-board PICkit 2 is still good for programming, just not debugging.
post edited by ajs410 - 2011/06/07 09:19:15
#82
DarioG
Allmächtig.
  • Total Posts : 54081
  • Reward points : 0
  • Joined: 2006/02/25 08:58:22
  • Location: Oesterreich
  • Status: offline
Re: RE: Firmware for Explorer 16, 18F4550 (U2) (unofficial) 2014/07/05 04:08:30 (permalink)
0
thank you Rafalw, after so many years Smile

GENOVA :D :D ! GODO
#83
Page: < 12345 Showing page 5 of 5
Jump to:
© 2018 APG vNext Commercial Version 4.5