• AVR Freaks

Hot!explorer16/32 with PIM (MA330019) dspic33fj128gp804

Author
leonardo yayo
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2021/03/04 06:24:40
  • Location: 0
  • Status: offline
2021/03/07 03:48:16 (permalink)
0

explorer16/32 with PIM (MA330019) dspic33fj128gp804

 
hello 
i want to use the explorer16/32 with the dspic33fj128gp804 ( MA330019)
the problem is that i can't program (see the image) https://imgur.com/a/ghFGzSz
i use the demo program for explorer 16/32
thank you
#1

3 Replies Related Threads

    du00000001
    Just Some Member
    • Total Posts : 4144
    • Reward points : 0
    • Joined: 2016/05/03 13:52:42
    • Location: Germany
    • Status: offline
    Re: explorer16/32 with PIM (MA330019) dspic33fj128gp804 2021/03/09 02:25:31 (permalink)
    0
    Looks a bit as if the Explorer board weren't connected.
    (IIRC light grey indicates devices that are known but currently not attached.)

    PEBKAC / EBKAC / POBCAK / PICNIC (eventually see en.wikipedia.org)
    #2
    leonardo yayo
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2021/03/04 06:24:40
    • Location: 0
    • Status: offline
    Re: explorer16/32 with PIM (MA330019) dspic33fj128gp804 2021/03/09 03:29:53 (permalink)
    0
    du00000001 
     
    the Explorer board is well connected. i did try other PIMs like ( pic24fj1024gb610 and dspic33ep512mu810 ) and there was no problem.
    this problem comes only with the PIM ( dspic33fj128gp804 ) , i tried 4 copies of IM ( dspic33fj128gp804 ) and same problem.  
    #3
    RISC
    Super Member
    • Total Posts : 6053
    • Reward points : 0
    • Status: offline
    Re: explorer16/32 with PIM (MA330019) dspic33fj128gp804 2021/03/09 04:02:18 (permalink)
    0
    Hi,
     
    Which MPLAB X version do you use ?
    Looking at your screenshot, there might be several reasons :
    1/ you have not updated the device_pack
    Please select  Device pack 1.3.64  (just above the compiler version in the project properties)
    2/ the debug tool you use is not up to date (also update the device pack for Pkob4 is there is one)
    https://microchipdeveloper.com/mplabx:projects-packs
    3/ the dspic33fj128gp804 could also not be supported with Pkob4 (pickit4)..
    Check MPLAB X compatibility
    [link=file:///C:/Program%20Files/Microchip/MPLABX/v5.45/docs/Device%20Support.htm]file:///C:/Program%20Files/Microchip/MPLABX/v5.45/docs/Device%20Support.htm[/link]
    It seems to me that it is fully supported
     
    Regards

    For support make sure to check first here : http://microchipdeveloper.com
    There are hundreds of PIC, AVR, SAM...which one do YOU use ?
    #4
    Jump to:
    © 2021 APG vNext Commercial Version 4.5