• AVR Freaks

KSZ8765 Autonegotiation disabled issues

Author
markov1983ap
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2020/03/26 00:47:53
  • Location: 0
  • Status: offline
2021/02/23 08:48:40 (permalink)
0

KSZ8765 Autonegotiation disabled issues

Hello everyone,
 
I've connected two copper ports of two distinct KSZ8765 and configured each switch to have autonegotiation disabled and 100BASE Full-Duplex mode. I have good traffic (no errors in traffic); it happens often that if i unplug/plug again the cables there are a lot of rx-symbol/rx-crc errors (i have issues with my application) but some frame pass. I noted that if i use 10BASE Full-Duplex the problem seems to disappear....Otherwise if i enable autonegotiation everything works; i had to disable autonegotiation for an issue with ACL rules writing.
 
Is there an issue with autonegotiation disabled on each end of the link? how does the port behave when link goes down-up? 
can someone help me?
 
Thanks
#1
XorLor
Junior Member
  • Total Posts : 83
  • Reward points : 0
  • Joined: 2009/10/23 00:17:05
  • Location: 0
  • Status: offline
Re: KSZ8765 Autonegotiation disabled issues 2021/02/23 10:30:01 (permalink)
0
markov1983ap
I noted that if i use 10BASE Full-Duplex the problem seems to disappear....Otherwise if i enable autonegotiation everything works
 

Everything works after it autonegotiates to what speed? 10BASE or 100BASE?
Sounds like a PCB layout and/or noise issue.
#2
markov1983ap
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2020/03/26 00:47:53
  • Location: 0
  • Status: offline
Re: KSZ8765 Autonegotiation disabled issues 2021/02/23 13:34:01 (permalink)
0
XorLor
 
Everything works after it autonegotiates to what speed? 10BASE or 100BASE?
Sounds like a PCB layout and/or noise issue.
 



Thanks for your answer. 
Oh sorry for my english...i would say that if i configure the ports to work in 10BASE Full Duplex with autonegotiation disabled, the problem doesn't exploit; i don't think there is an issue with pcb because if i never plug the cable the frames are all good with 100BASE...the problem shows only after a unplug-plug of cables. as i said, if i start with no autonegotiation and 10BASE it works also with unplug/plug. 
 
that's the situation:
1. start the switch with autonegotiation disabled and 100BASE full duplex (on both ends of link)
2. traffic is all correct (i increased the traffic rate and leave the system running whole day, 24 hours) .. no drop or any kind of error in the mibs
3. unplug...wait a bit...plug again
4. in the case of malfunction, the activity led related to one of the end of the link blinks too fast than it should (my traffic is very slow, a frame each 500ms) and i see a lot of symbol error on rx port but not all packets are corrupted; some are received correctly. i don't know why...
5. if i unplug/replug it starts to work again (not always but often).
 
If i run the same steps configuring 10BASE Full duplex with no autonegotiation it works in every case.
 
sorry again for my english, hope you can help me :D
#3
Jump to:
© 2021 APG vNext Commercial Version 4.5