• AVR Freaks

Hot!10 000 crystal oscillator

Author
Gorro
Starting Member
  • Total Posts : 48
  • Reward points : 0
  • Joined: 2019/03/07 04:12:52
  • Location: 0
  • Status: offline
2021/02/18 13:12:43 (permalink)
0

10 000 crystal oscillator

please if I got a 10 000 crystal oscillator how do I set my pic18f4550 configurations.
#1

18 Replies Related Threads

    1and0
    Access is Denied
    • Total Posts : 12269
    • Reward points : 0
    • Joined: 2007/05/06 12:03:20
    • Location: Harry's Gray Matter
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/18 13:16:22 (permalink)
    +1 (1)
    Gorro
    please if I got a 10 000 crystal oscillator how do I set my pic18f4550 configurations.

    EC oscillator mode.
    #2
    ric
    Super Member
    • Total Posts : 30244
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/18 14:16:53 (permalink)
    +2 (2)
    That is assuming you are using the term "crystal oscillator" correctly.
    i.e. a powered device that has power pins, and a single clock output pin (so at least three legs).
     
    If it is in fact just a quartz crystal (with two legs), then you will need to use "HS" mode, and also install appropriate load capacitors.
     
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #3
    ric
    Super Member
    • Total Posts : 30244
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/18 14:34:50 (permalink)
    +2 (2)
    I'm also assuming that "10 000" actually means 10 MHz.
    If it's actually 10,000 Hertz = 10 kHz, that changes everything...
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #4
    1and0
    Access is Denied
    • Total Posts : 12269
    • Reward points : 0
    • Joined: 2007/05/06 12:03:20
    • Location: Harry's Gray Matter
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/18 15:55:36 (permalink)
    +4 (4)
    Incomplete question gets incomplete answers. ;)
     
    #5
    Gorro
    Starting Member
    • Total Posts : 48
    • Reward points : 0
    • Joined: 2019/03/07 04:12:52
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 01:11:51 (permalink)
    +1 (1)

     
    https://en.wikipedia.org/...File:16MHZ_Crystal.jpg
     
    I got like this one but 10 000
    #6
    ric
    Super Member
    • Total Posts : 30244
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 01:27:20 (permalink)
    0
    So I assume it is actually "10.000" not "10 000"

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #7
    Gorro
    Starting Member
    • Total Posts : 48
    • Reward points : 0
    • Joined: 2019/03/07 04:12:52
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 01:31:22 (permalink)
    0
    true
    #8
    Gorro
    Starting Member
    • Total Posts : 48
    • Reward points : 0
    • Joined: 2019/03/07 04:12:52
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 01:32:23 (permalink)
    0
    PK2Error0027:  Failed verify (Address = 0x0 - Expected Value 0xEFC7 - Value Read 0x0)
    now I am getting this type of error everywhere even on old programs that were working before
    #9
    oliverb
    Super Member
    • Total Posts : 441
    • Reward points : 0
    • Joined: 2009/02/16 13:12:38
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 01:43:20 (permalink)
    0
    Check the programmer is correctly connected to the PIC.
    Try erasing the PIC.
     
    #10
    Gorro
    Starting Member
    • Total Posts : 48
    • Reward points : 0
    • Joined: 2019/03/07 04:12:52
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 01:50:18 (permalink)
    0
    I did erase it many times and I have done reset to the pikit2 and still.
    I am trying to download the software for pikit2
    #11
    oliverb
    Super Member
    • Total Posts : 441
    • Reward points : 0
    • Joined: 2009/02/16 13:12:38
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 02:22:42 (permalink)
    0
    Is the PICkit still responding to commands? Are you getting ID mismatch errors? If the PIC is not connected or bricked then usually you'll see an error about an incorrect device ID. Otherwise I believe code protection will result in all locations reading as "00", but I haven't used CP in years. If it is CP then a full erase should restore the PIC.
     
    Also could you measure the PIC supply voltage.
    #12
    RISC
    Super Member
    • Total Posts : 6067
    • Reward points : 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/23 05:57:52 (permalink)
    +4 (4)
    Hi,
    You must use "HS" for oscillator selection because what you use is a XTAL, not an external oscillator (EC).
    Please show your schematics
    regards

    For support make sure to check first here : http://microchipdeveloper.com
    There are hundreds of PIC, AVR, SAM...which one do YOU use ?
    #13
    Jams100001
    Senior Member
    • Total Posts : 96
    • Reward points : 0
    • Joined: 2018/04/12 13:37:33
    • Location: MCHP Chandler
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/24 10:14:02 (permalink)
    +1 (1)
    Gorro,
    Make sure your part isn't in reset. Sometimes the older microchip parts need a pullup resistor on MCLR to allow the part to start running code. 
    Jamus
    #14
    Gorro
    Starting Member
    • Total Posts : 48
    • Reward points : 0
    • Joined: 2019/03/07 04:12:52
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/27 04:43:12 (permalink)
    0
    Hi jams thank you for helping me, I am connecting a 1K resistor at MCLR but it used to work should I change it to 10K?
    #15
    ric
    Super Member
    • Total Posts : 30244
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/27 04:53:25 (permalink)
    +1 (1)
    Either 1k or 10k pull up on MCLR should work fine.

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #16
    Gorro
    Starting Member
    • Total Posts : 48
    • Reward points : 0
    • Joined: 2019/03/07 04:12:52
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/27 06:13:07 (permalink)
    0
    I thing I found the problem that pikit 2 is giving 3.3v not 5v how can I increase the voltage?
     
    #17
    PStechPaul
    Super Member
    • Total Posts : 3047
    • Reward points : 0
    • Joined: 2006/06/27 16:11:32
    • Location: Cockeysville, MD, USA
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/27 16:52:44 (permalink)
    +2 (2)
    Select desired voltage in properties.
     
    Also make sure the processor clock is running. There is also a separate USB clock. Show your code, especially CONFIG settings.

     
    #18
    Gorro
    Starting Member
    • Total Posts : 48
    • Reward points : 0
    • Joined: 2019/03/07 04:12:52
    • Location: 0
    • Status: offline
    Re: 10 000 crystal oscillator 2021/02/28 11:11:32 (permalink)
    0
    ahh I the code was working 100% before I changed nothing. I tried many codes that were working before and I am getting the same error sad: sad.
    Maybe my pic18f4550 is not working anymore.
    #19
    Jump to:
    © 2021 APG vNext Commercial Version 4.5