• AVR Freaks

Hot!Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu..."

Author
Cary
Starting Member
  • Total Posts : 21
  • Reward points : 0
  • Joined: 2021/01/19 12:17:11
  • Location: 0
  • Status: offline
2021/01/26 16:27:03 (permalink)
5 (1)

Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu..."

Hi,
 
I am using MPLAB X IDE v5.45 and I am trying to use the simulator.   I can load the project to my PIC16F15244  Curiosity Nano board, but when I change to the simulator, I get the error below:
 
     Launching
     Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simulator.Simulator
     The debugger could not be started. Terminating debug session.
     User program finished
 
Here is what I am doing after a successful loading of the board:
   - right click on projects -> project_name
   - scroll to bottom and select 'properties'
   - Change the "Connected Hardware Tool" to simulator
   - Click on "Debug Main Project" icon
   ... The error above shows up in the "Debugger Console".  
 
As noted above, if I am not using the "simulator" as the "Connected Hardware Tool" (above), and I use the actual hardware (instead of "simulator", above, select "PIC16F244 Curiosity Nano-SN ....." then it debugs fine without using the simulator.
 
Please advise.  Thank you.
#1

6 Replies Related Threads

    dan1138
    Super Member
    • Total Posts : 4242
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu 2021/01/26 17:21:56 (permalink)
    +2 (2)
    Ok, seems there is good new and bad news.
     
    The bad news is Microchip has screwed up the MPLABX simulator integration for the PIC16F15244.
    (Yeah big surprise here)
     
    The good news is that the PIC16F15245 (same package, more code and RAM) seems to work in the simulator.
    #2
    ric
    Super Member
    • Total Posts : 29861
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu 2021/01/26 17:26:38 (permalink)
    -1 (1)
    I don't know why the simulator is failing for you, but I'm curious why you want to use the software simulator if you have the real hardware available.
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #3
    Cary
    Starting Member
    • Total Posts : 21
    • Reward points : 0
    • Joined: 2021/01/19 12:17:11
    • Location: 0
    • Status: offline
    Re: Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu 2021/01/26 18:13:37 (permalink)
    0
    I am new to PIC uControllers and trying to learn with some example code. I will not always have the hardware so this seems important.
     
    dan1138 (thank you Dan) did help.  Changing to the PIC16F15245 did get rid of the error, but now I see: 
     
      "No tool device file"
     
    Am I doing something wrong?
    #4
    dan1138
    Super Member
    • Total Posts : 4242
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu 2021/01/26 22:02:10 (permalink)
    -1 (1)
    Cary
    I am new to PIC uControllers and trying to learn with some example code. I will not always have the hardware so this seems important.
     
    dan1138 (thank you Dan) did help.  Changing to the PIC16F15245 did get rid of the error, but now I see: 
     
      "No tool device file"
     
    Am I doing something wrong?

    Don't know, cannot tell what you did to get that message.
    #5
    Cary
    Starting Member
    • Total Posts : 21
    • Reward points : 0
    • Joined: 2021/01/19 12:17:11
    • Location: 0
    • Status: offline
    Re: Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu 2021/01/27 16:11:08 (permalink)
    0
    Hi Dan1138,
     
    I right clicked on the project, scrolled down to properties, and in the Project Properties window I selected "Device:" as PIC16F15245 as you noted in your earlier message (I am using the PIC16F15244).  I selected "Simulator" for the Connected Hardware Tool. Then I ran "Debug Main Project" in the main window again.
     
    That got rid of the first error, but then the "No tool device file" error appeared. 
    #6
    dan1138
    Super Member
    • Total Posts : 4242
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Getting "Tool software could not be found: Simulator, com.microchip.mplab.mdbcore.simu 2021/01/27 18:34:45 (permalink)
    0
    I am doing the same thing you did in post#6
     
    Attached are screen captures of what I see.
     
    I am baffled by what you have observed.

    Attached Image(s)

    #7
    Jump to:
    © 2021 APG vNext Commercial Version 4.5