• AVR Freaks

Hot!Hopefully a simple MCC question

Author
JohnWill
Starting Member
  • Total Posts : 65
  • Reward points : 0
  • Joined: 2012/07/01 09:36:18
  • Location: 0
  • Status: offline
2020/09/27 09:23:11 (permalink)
0

Hopefully a simple MCC question

I'm attempting to configure the weak pullups using MCC with version 5.40.  I am getting this error.
 
Please enable nWPUEN bit from register view.
I believe I am in register view, so how do I get rid of this warning.  Perhaps I just don't know what Register view is?

 
I've attached the screen, if this isn't register view, where do I find that? :)

Attached Image(s)

#1

4 Replies Related Threads

    dan1138
    Super Member
    • Total Posts : 3998
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Hopefully a simple MCC question 2020/09/27 09:56:37 (permalink)
    4 (1)
    JohnWill
    I'm attempting to configure the weak pullups using MCC with version 5.40.  I am getting this error.
     
    Please enable nWPUEN bit from register view.
    I believe I am in register view, so how do I get rid of this warning.  Perhaps I just don't know what Register view is?

    This question is a whole lot easier to answer when you post the part number of the Microchip controller you are using.
    #2
    Mysil
    Super Member
    • Total Posts : 3952
    • Reward points : 0
    • Joined: 2012/07/01 04:19:50
    • Location: Norway
    • Status: offline
    Re: Hopefully a simple MCC question 2020/09/27 10:27:42 (permalink)
    0
    Hi,
        nWPUEN     bit is a control bit in OPTION_REG, 
    which may be in Register View for a entirely different window of MCC,
    most probably in 'System Module'.
    Instead of logic handling registers in different 'Modules',
    someone have taken a easy way out, and made a hint message instead of more complicated logic.
    I am not convinced that you will be able to get rid of the notification message.
     
        Mysil
    #3
    JohnWill
    Starting Member
    • Total Posts : 65
    • Reward points : 0
    • Joined: 2012/07/01 09:36:18
    • Location: 0
    • Status: offline
    Re: Hopefully a simple MCC question 2020/09/27 10:50:34 (permalink)
    0
    Actually, I did manage to get rid of the error.  It was a bit obscure, I went back to the datasheet for the 12F1501 and saw that you have to enable the pullup feature in the config registers, then you can enable it for individual ports.  It would have been nice to have a slightly more illuminating error message, but I made it to the finish line.
    #4
    dan1138
    Super Member
    • Total Posts : 3998
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Hopefully a simple MCC question 2020/09/27 11:09:32 (permalink)
    4 (1)
    JohnWill
    ... It would have been nice to have a slightly more illuminating error message, but I made it to the finish line.

    Count yourself lucky that you are using one of the new versions of MCC that has some diagnostic messages.
    #5
    Jump to:
    © 2020 APG vNext Commercial Version 4.5