• AVR Freaks

Hot!RN4870 - Connects on one Win10 PC, but not another using the same app

Author
sirhC_sirhC
Starting Member
  • Total Posts : 58
  • Reward points : 0
  • Joined: 2011/06/22 11:57:51
  • Location: Chicago
  • Status: offline
2020/09/16 10:15:26 (permalink)
0

RN4870 - Connects on one Win10 PC, but not another using the same app

I developed an Win10 UWP app (based on their BluetoothLE SDK example) which talks great to the RN4870, I was all done.  but.. when I tried it on other PCs, it wont Connect.  On all machines it pairs. But some wont connect. I've been trying to find out why.  
On a Good Machine, the PC tries to connect; this comes out this out on the RN4870:
%CONNECT,0,982CBC6906B2%%SECURED%
 
On a Bad Machine (running the same app, same Win10 revision level) it gets this
%CONNECT,0,F06E0BC5CE8B%%ERR_SEC%%DISCONNECT%
 
Anyone recognize the error string, or what it might mean?  ERR_SEC  is that security?  like some idk permission thing?
 
I tried to tie it to BT modem software revision but that didnt link. (2) Good machines were BT5.0 and BT4.0, bad BT5.0 and BT4.8.  Took the good 4.0 fob and stuck it in the 4.8 machine and it STILL fails for the same reason.  
post edited by sirhC_sirhC - 2020/10/01 04:39:24
#1

1 Reply Related Threads

    sirhC_sirhC
    Starting Member
    • Total Posts : 58
    • Reward points : 0
    • Joined: 2011/06/22 11:57:51
    • Location: Chicago
    • Status: offline
    Re: RN4870 - Connects on one PC, but not another using the same app 2020/09/19 07:37:28 (permalink)
    4 (1)
    Sorry no solution.  Tried using the IsConnectible field to see if the device is ready.
    Unfortunately on a good machine it is flickering (at least sometimes connectible) on a bad machine it is never connectible.
    Could really use some advice.
    post edited by sirhC_sirhC - 2020/10/06 07:12:11
    #2
    Jump to:
    © 2020 APG vNext Commercial Version 4.5