• AVR Freaks

Hot!Atmel 89c5115 can't get to the bootloader. Any ideas?

Author
Recurve1
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/08/26 13:01:44
  • Location: 0
  • Status: offline
2020/08/28 07:30:23 (permalink)
0

Atmel 89c5115 can't get to the bootloader. Any ideas?

Hoping this is the right place to ask.  I have a SIMPLE board with a Atmel AT89C5115, a FTDI USB chip FT230 to TX and RX.  12MHz crystal and caps, a reset button and voltage regulator. I have made (2) identical boards. 4.7uF cap on reset to Vcc.  All of the other pins connect to a header pin.  I can see the crystal running, VCC and Gnd at the proper values.  I see the ascii character "U" coming into the 89c5115 rx pin but there is nothing on the Tx pin.  It should be echoing the "U" character.  I have tried a 22uf cap in the reset circuit. Multiple Resets and combinations of power/reset/Flip software but I can not get past this point.  Does anyone have any additional ideas of what to try next? Thanks in advance for your help.
I have tried disconnecting the TX on the uP so that it is not connected to anything, still nothing.

Attached Image(s)

#1

0 Replies Related Threads

    Jump to:
    © 2020 APG vNext Commercial Version 4.5