• AVR Freaks

Hot!PICKIT 4 not able to enter debuging mode.

Author
A.T.
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2020/07/31 03:34:23
  • Location: 0
  • Status: offline
2020/08/02 21:21:42 (permalink)
0

PICKIT 4 not able to enter debuging mode.

I'm using MPLAB V5.0 with XC16 v1.34 with PIC24FJ128GC006 and PICKIT 4. I'm able to program the controller but when I try to enter debug mode it throws the following error message:-
 
Script GetVersionDE failed with status Type = runScript, Script name = GetVersionDE, Status = 0xa00
data: 0:
.
The target device is not ready for debugging. Please check your configuration bit settings and program the device before proceeding. The most common causes for this failure are oscillator and/or PGC/PGD settings.
 
This message started popping up after I used the same PICKIT 4 on a different PC before that it was entering in debug mode.
#1

1 Reply Related Threads

    DevMod1
    Administrator
    • Total Posts : 532
    • Reward points : 0
    • Joined: 2009/02/10 09:34:30
    • Location: 0
    • Status: offline
    Re: PICKIT 4 not able to enter debuging mode. 2020/08/03 09:19:43 (permalink)
    0
    MPLAB X v5.0 is pretty old, please download and install MPLAB X v5.40 after goto Tools->Packs click on the Tool Pack tab and update the ICD4 and PICkit 4 toolpacks. 

    _____________________________

    Please read the forum posting guidelines. Do not double post, please help keep these forums professional and comments respectful.
    Please notify the moderators of problems/spam/trolls.
    #2
    Jump to:
    © 2020 APG vNext Commercial Version 4.5