• AVR Freaks

Hot!Unable to resolve identifier

Author
Dommel
New Member
  • Total Posts : 6
  • Reward points : 0
  • Joined: 2020/05/16 02:08:53
  • Location: 0
  • Status: offline
2020/08/02 06:16:10 (permalink)
1 (1)

Unable to resolve identifier

Hello,
 
I have generated a code with MCC where I' like tot toggel RC9. The board is a Curiosity Board with PIC32MM0064GPL036 - RC9 connected to LED.
When I build I get the following error when I use ...
IO_RC9_SetHigh();
Does anybody have an idea, why the complice complain? I use MPLAB v5.40 and XC32v2.41
#1

2 Replies Related Threads

    katela
    Super Member
    • Total Posts : 1927
    • Reward points : 0
    • Joined: 2013/06/11 05:25:18
    • Location: South Africa
    • Status: offline
    Re: Unable to resolve identifier 2020/08/02 09:16:21 (permalink)
    +1 (3)
    You did not specify the error you are getting.
    Can you post the complete build log?

    Free online Microcontroller Tutorials and Projects for Hobbyists and students. From beginners to advanced. Website: www.studentcompanion.co.za
    YouTube Tutorials: https://www.youtube.com/StudentCompanionSA
    #2
    Ddhar
    New Member
    • Total Posts : 6
    • Reward points : 0
    • Joined: 2020/05/14 22:52:08
    • Location: 0
    • Status: offline
    Re: Unable to resolve identifier 2020/08/03 10:39:52 (permalink)
    0
    This is coming from the pre-parser connected to MPLAB X IDE. 
    The pre-parser doesn't have the knowledge of the symbol / isn't able to resolve the symbol. 
    However, the code should build fine and compiler will complain if there's anything wrong with the code. 
     
    To fix the IDE's pre-parser you must submit your code via a support ticket.  
    #3
    Jump to:
    © 2021 APG vNext Commercial Version 4.5