• AVR Freaks

Hot!5.40 'javaws.exe' shortcut problem ?

Author
K8LH
Super Member
  • Total Posts : 1878
  • Reward points : 0
  • Joined: 2004/03/26 05:12:34
  • Location: Michigan, USA
  • Status: offline
2020/07/10 06:03:44 (permalink)
5 (1)

5.40 'javaws.exe' shortcut problem ?

I'm using windows 7 and recently installed MPLABX 5.40 and I'm still exploring and trying to figure out how to install MPASMWIN but ran across this problem (below).  Help, please?
 
TIA...  Cheerful regards, Mike, K8LH
 
 
post edited by K8LH - 2020/07/10 06:06:31

Attachment(s)

Attachments are not available: Download requirements not met
#1

5 Replies Related Threads

    ric
    Super Member
    • Total Posts : 28009
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: 5.40 'javaws.exe' shortcut problem ? 2020/07/10 06:10:44 (permalink)
    -1 (1)
    You shouldn't need to do any extra step. MPASM should be available as soon as you install MPLABX. why do you think you need to add it?
     
    Edit. Didn't notice the question was about MPLABX v5.40, which does NOT install MPASM
    post edited by ric - 2020/07/10 14:38:24

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #2
    mbrowning
    USNA79
    • Total Posts : 1791
    • Reward points : 0
    • Joined: 2005/03/16 14:32:56
    • Location: Melbourne, FL
    • Status: offline
    Re: 5.40 'javaws.exe' shortcut problem ? 2020/07/10 06:12:12 (permalink)
    0
    I thought MPASM wasn't compatible with MPLAB-X 5.40 because of the 64b thing?
    #3
    K8LH
    Super Member
    • Total Posts : 1878
    • Reward points : 0
    • Joined: 2004/03/26 05:12:34
    • Location: Michigan, USA
    • Status: offline
    Re: 5.40 'javaws.exe' shortcut problem ? 2020/07/10 06:20:28 (permalink)
    +1 (1)
    ric
    You shouldn't need to do any extra step. MPASM should be available as soon as you install MPLABX. why do you think you need to add it?

    Because I found this in the release notes for version 5.40 (below)??? 
     
    Attachments are not available: Download requirements not met
    post edited by K8LH - 2020/07/10 06:27:54

    Attachment(s)

    Attachments are not available: Download requirements not met
    #4
    ric
    Super Member
    • Total Posts : 28009
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: 5.40 'javaws.exe' shortcut problem ? 2020/07/10 06:50:52 (permalink)
    +1 (1)
    Sorry, I missed that you had moved up to 5.40.
    The answer is "you can't " which is why they don't.
    MPLABX v5.40 requires 64 bit tools, and MC can't be bothered doing a 64 bit version of MPASM. That's why it is no longer installed, so you have no hope of manually installing it.

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #5
    Jerry Messina
    Super Member
    • Total Posts : 540
    • Reward points : 0
    • Joined: 2003/11/07 12:35:12
    • Status: offline
    Re: 5.40 'javaws.exe' shortcut problem ? 2020/07/10 12:02:06 (permalink)
    +1 (1)
    ricMPLABX v5.40 requires 64 bit tools...

    Actually, it doesn't (at least not on win7 x64). After all the ballyhoo, I thought so at first too, but I've installed other 32-bit build tools I have into MPLABX 5.40 and they work fine. Even ones that use MPASM.
     
    What I haven't been able to do so far is install MPASM as a build tool directly into MPLABX 5.40 and use it.
    I haven't figured out the secret incantation...
    post edited by Jerry Messina - 2020/07/11 06:16:39
    #6
    Jump to:
    © 2020 APG vNext Commercial Version 4.5