• AVR Freaks

Hot!DNS Issues with Harmony V1.11

Author
NKurzman
A Guy on the Net
  • Total Posts : 18858
  • Reward points : 0
  • Joined: 2008/01/16 19:33:48
  • Location: 0
  • Status: online
2020/07/08 07:55:02 (permalink)
0

DNS Issues with Harmony V1.11

More Network Issues for Me.   Harmony V1.11
I am having a issue where the Initial DNS Lookup works.
Later on it fails. I am told the DNS will use its "Hosts" file for look ups after it find an Address. The that will last 24 hours. After that it will lookup the address on the DNS server to see if it changed.
This second lookup appears to be the Issue. gethostbyname() always returns NULL.
 
Has this issue been seen before?
#1

9 Replies Related Threads

    friesen
    Super Member
    • Total Posts : 2148
    • Reward points : 0
    • Joined: 2008/05/08 05:23:35
    • Location: Indiana, USA
    • Status: offline
    Re: DNS Issues with Harmony V1.11 2020/07/08 09:08:24 (permalink)
    0
    Perhaps not applicable, but are you rather sure there isn't an upstream switch doing brain dead stuff?

    Erik Friesen
    #2
    NKurzman
    A Guy on the Net
    • Total Posts : 18858
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: online
    Re: DNS Issues with Harmony V1.11 2020/07/08 09:33:04 (permalink)
    0
    As this Point I do not know anything.  But I suspect the issue is at more than one site.
    But not everyone.  But is seems related to the Unit.  The IT at the site is going to log the DNS requests from me to the Server.  The fact that it can be recovered in SW makes it look like a Stack issue. And that it is OK he is annoying.
     
    #3
    rainad
    Moderator
    • Total Posts : 1387
    • Reward points : 0
    • Joined: 2009/05/01 13:39:25
    • Location: 0
    • Status: offline
    Re: DNS Issues with Harmony V1.11 2020/07/08 10:20:17 (permalink)
    0
    There's been updates, fixes, etc. for DNS since v1.x days.
    Maybe you can try to update the DNS module itself to the latest version, like you did for DHCP?
    Probably it will work.
    If need to tweak/disable something because the build fails - there's been new features like signaling in the stack too - I can help.
     
     
    #4
    NKurzman
    A Guy on the Net
    • Total Posts : 18858
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: online
    Re: DNS Issues with Harmony V1.11 2020/07/08 10:39:44 (permalink)
    0
    Rainad I though that maybe the case.
    Is there a way to reproduce the Issue, so I can see that it is fixed? I hate to send Customers "Try This" Code.
    It looks like just DNS.C and DNS.H? (plus any other dependencies)
    At some point I need to try a full move to V2.06  I am not sure if a move to V3.XX would be possible with with my code.  At least not without a lot of work.
     
    Thank You for you Advice.
    #5
    NKurzman
    A Guy on the Net
    • Total Posts : 18858
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: online
    Re: DNS Issues with Harmony V1.11 2020/07/08 10:52:27 (permalink)
    0
    Rainad
     
    Slightly off Topic.
    But did the Stack in Harmony V1.11 have any issues with a subnet mask of
    255.255.255.192 Ping seems to work, but Berkley Sockets do not communicate.
    #6
    rainad
    Moderator
    • Total Posts : 1387
    • Reward points : 0
    • Joined: 2009/05/01 13:39:25
    • Location: 0
    • Status: offline
    Re: DNS Issues with Harmony V1.11 2020/07/08 11:21:36 (permalink)
    0
    I understand that the approach "try this, maybe it works" is not something to be considered.
    Yes, the issue should be solved.
    Is this issue noticed when DNS itself is called or only through BSD API gethostbyname()?
    (There is no "hosts" file maintained by the Harmony DNS, but it has its cache where it stores the solved names).
    Once I know this I can look and make a comparison between DNS files in v1.11 and what we have now, hopefully I'll be able to see something that would explain the issues.
     
     
    Is there a way to reproduce this issue? You're saying that occurs only at some sites.
     
     
    P.S. I'm not aware of an issue with the 255.255.255.192 mask. But, again, v1.11 was a long time ago.
    You think this happens only with BSD sockets or with native sockets as well?
     
    #7
    NKurzman
    A Guy on the Net
    • Total Posts : 18858
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: online
    Re: DNS Issues with Harmony V1.11 2020/07/08 11:57:37 (permalink)
    0
    Rainad
     
    Just with gethostbyname()
    I was hoping you knew a way to force the error to happen.
    It does not appear to be everywhere.  Just certain locations.  I do not know it it is related to the DNS server Software.
    I will see if it is failing at closer locations.
    I understand that the equivalent of Hosts is virtual.
     
    The 255.255.255.192 mask issue.  I need to dig in to this.  Ping works.  But it will not communicate with a client ( I have to check if it is UDP or TCP)
     
    #8
    rainad
    Moderator
    • Total Posts : 1387
    • Reward points : 0
    • Joined: 2009/05/01 13:39:25
    • Location: 0
    • Status: offline
    Re: DNS Issues with Harmony V1.11 2020/07/08 13:17:46 (permalink)
    0
    I did a quick comparison between the v1.11 that you use and the v2.06 version of DNS.
    There is a bug that has been fixed - missing a TCPIP_UDP_DestinationPortSet() after binding the socket - that may explain what you see.
    I suggest you simply use the v2.06 version of dns.c, dns.h, dns_private.h and dns_manager.h. It should build without any issues.
     
    I know that it would be better to really prove that the issue does not occur with the new version.
    So if you find any more info on how to run into this issue, we can run some tests to be sure.
     
     
     
    #9
    NKurzman
    A Guy on the Net
    • Total Posts : 18858
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: online
    Re: DNS Issues with Harmony V1.11 2020/07/08 15:29:32 (permalink)
    0
    I think the Issue maybe at location closer to me.
    I will Investigate.
     
    Thank You
    #10
    Jump to:
    © 2020 APG vNext Commercial Version 4.5