• AVR Freaks

Hot!net repo v3.6.1 problem

Author
BillP
Super Member
  • Total Posts : 414
  • Reward points : 0
  • Joined: 2014/09/28 07:53:35
  • Location: CA
  • Status: offline
2020/07/05 08:09:51 (permalink)
0

net repo v3.6.1 problem

I have updated my repos to the latest versions and when I compile a project using the wolfssl library I get a compile error (see attached).  I checked the versions in the content manager and there appears to be an inconsistency.  The net v3.6.1 shows a dependency on wolfssl v4.3.0, however the latest repo is wolfssl v4.4.0.  Is this the source of the error?

Attached Image(s)

#1

1 Reply Related Threads

    rainad
    Moderator
    • Total Posts : 1384
    • Reward points : 0
    • Joined: 2009/05/01 13:39:25
    • Location: 0
    • Status: offline
    Re: net repo v3.6.1 problem 2020/07/06 06:17:25 (permalink)
    0
    A net release relies on specific package versions, listed in net/package.xml.
    To build a net demo in a net release, these versions need to be present/respected, mix and match won't work.
    If a newer version of wolfSSL is used instead, there will be build errors, unless somebody performs the required integration work.
    This is true for all net releases, including the last one, 3.6.0/3.6.1.
     
    #2
    Jump to:
    © 2020 APG vNext Commercial Version 4.5