• AVR Freaks

Hot!Logic Analyzer not working with MPLAB V5.40 using PIC24FJ128GA010

Author
MTSPIKE
Starting Member
  • Total Posts : 45
  • Reward points : 0
  • Joined: 2017/05/10 05:46:22
  • Location: 0
  • Status: offline
2020/06/30 07:04:19 (permalink)
0

Logic Analyzer not working with MPLAB V5.40 using PIC24FJ128GA010

 
I recently installed MPLAB X IDE V5.40.  The processor I'm using is the PIC24FJ128GA010.  I've not been able to get the Logic Analyzer to work as it has with previous Versions.  
The program I'm running is very small, it simply toggles PORTA (or PORTB) logic levels hi and low in a while(1) loop.  
  1. If I go back to MPLAB X IDE V5.25, and use the exact same Project, the Simulator Logic Analyzer works.
  2.  The Simulator Watch windows (i.e., Window > Debugging > Watches) do work, using V5.40, I can see the PORT values change when I single step (i.e., Step Into)
  3. If leave Simulation, and actaully program the PIC24FJ128GA010 (on an Explorer 16/32 board), the signal levels do assert properly.
#1

5 Replies Related Threads

    GeorgePauley
    Moderator
    • Total Posts : 1268
    • Reward points : 0
    • Joined: 2009/12/01 13:59:30
    • Location: Chandler AZ
    • Status: offline
    Re: Logic Analyzer not working with MPLAB V5.40 using PIC24FJ128GA010 2020/06/30 08:00:44 (permalink)
    +2 (2)
    Logic Analyzer is broken in 5.40.  It should be working again in 5.45.
    #2
    MTSPIKE
    Starting Member
    • Total Posts : 45
    • Reward points : 0
    • Joined: 2017/05/10 05:46:22
    • Location: 0
    • Status: offline
    Re: Logic Analyzer not working with MPLAB V5.40 using PIC24FJ128GA010 2020/07/01 14:18:02 (permalink)
    +1 (1)
    Mr. GeorgePauley,
    Thank you for the information.
    1) When will V5.45 be released?
    2) Is the Stopwatch also broken?  
     
    #3
    dan1138
    Super Member
    • Total Posts : 3841
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Logic Analyzer not working with MPLAB V5.40 using PIC24FJ128GA010 2020/07/01 14:59:12 (permalink)
    +2 (2)
    This link should bring up a list of release announcements made be DevMod1.

    The list suggests that we can begin to expect the next MPLBX release in August.
    #4
    PStechPaul
    Super Member
    • Total Posts : 2919
    • Reward points : 0
    • Joined: 2006/06/27 16:11:32
    • Location: Cockeysville, MD, USA
    • Status: online
    Re: Logic Analyzer not working with MPLAB V5.40 using PIC24FJ128GA010 2020/09/02 18:25:49 (permalink)
    0
    I just experienced this problem with a PIC16F1825 project. The logic analyzer works in 5.35 but not 5.40. I hope 5.45 will be released soon.
     
    BTW, I also clicked on the link in "Compiler Downloads" to download XC8 2.20 and it was actually 2.30.

     
    #5
    PStechPaul
    Super Member
    • Total Posts : 2919
    • Reward points : 0
    • Joined: 2006/06/27 16:11:32
    • Location: Cockeysville, MD, USA
    • Status: online
    Re: Logic Analyzer not working with MPLAB V5.40 using PIC24FJ128GA010 2020/09/02 22:52:39 (permalink)
    0
    It also seems like MPLABX must be closed and restarted when switching between simulator and PICkit3.

     
    #6
    Jump to:
    © 2020 APG vNext Commercial Version 4.5