• AVR Freaks

Hot!PIC24FG64GA702 Takes long time to complete programming.

Author
Kartha
New Member
  • Total Posts : 22
  • Reward points : 0
  • Joined: 2017/07/14 21:44:40
  • Location: 0
  • Status: offline
2020/06/23 21:55:59 (permalink)
0

PIC24FG64GA702 Takes long time to complete programming.

Hello all, 
In one of my projects I used PIC24FJ64GA702 16 bit microcontroller. All decaps Core caps and MCLR reset circuit were soldered correctly, and the voltage rail shows 3.3 volts. The voltage at core cap pin is 1.8 volts. All these seems the pic is properly soldered and ready to work. 
The issue am facing right now is, the programming is taking around 1 minute to complete. More precisely, device ID revision is showing perfectly, after that erasing is done, and then the programming log shows Configuration memory and stuck there for more than a minute. After that programming finishes.
For details I have attached a picture that shows the programming log.
I have used PIC24FJ64GA702 a couple of times long back, may be 1 year back, at that time such problems were not there.
Do any one know the exact reason for this slow programming? Or is this normal?
Please share your thoughts and experience.
Thanks in advance. 
 

Attached Image(s)

#1

8 Replies Related Threads

    ric
    Super Member
    • Total Posts : 27954
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/23 22:06:36 (permalink)
    0
    One details you forgot to mention is what programmer you are using.
    From the tab name in your screen shot, I would guess it is a SNAP.
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #2
    Kartha
    New Member
    • Total Posts : 22
    • Reward points : 0
    • Joined: 2017/07/14 21:44:40
    • Location: 0
    • Status: offline
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/23 22:17:23 (permalink)
    0
    Thanks ric, Sorry for not mentioning the programmer name. Your guess is correct, its a SNAP programmer. But I tried PICKIT4 also, same delay. And also tried using different PC, but no success. 
    #3
    RISC
    Super Member
    • Total Posts : 5772
    • Reward points : 0
    • Status: online
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/24 03:02:19 (permalink)
    0
    Hi,
    I think I faced that issue several months ago on this particular device (28pins) and it may be related to one of the ICSP pairs which has a limitation (I checked the errata and there is nothing about that).
    Can you please try another ICSP pair and see if you get better results ?
    Regards
    #4
    Kartha
    New Member
    • Total Posts : 22
    • Reward points : 0
    • Joined: 2017/07/14 21:44:40
    • Location: 0
    • Status: offline
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/24 03:14:24 (permalink)
    0
    Hello RISC, let me check the feasibility of doing that. If I can, I will try it and let you know the result.
    Thanks for your suggestion.
    #5
    RISC
    Super Member
    • Total Posts : 5772
    • Reward points : 0
    • Status: online
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/24 09:15:00 (permalink)
    0
    Hi,
    Which MPLAB X version do you use ?
    At the time I had the issue it was MPLAB X v4.20 (2018). It was expecially slow to enter debug mode in MPLAB X and I think tech support was telling me that something would be also corrected in a future MPLAB X release >= v5.00.
    Can't find the details anymore...
    Regards 

    For support make sure to check first here : http://microchipdeveloper.com
    There are hundreds of PIC, AVR, SAM...which one do YOU use ?
    #6
    Kartha
    New Member
    • Total Posts : 22
    • Reward points : 0
    • Joined: 2017/07/14 21:44:40
    • Location: 0
    • Status: offline
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/24 09:21:41 (permalink)
    0
    Hi RISC, it is MPLAB XIDE v5.05, XC16v1.26. And also I made a quick schematic check as u said. The current PCB am using have PGD2 and PGC2 (the one which is slower), and the one I have used earlier (1 year back) have PGD1 and PGC1 program pins which have no issues.
    May be this could be the reason as you mentioned. When I get time I will check this for sure and let u know.
    Can u please tell me from where did you get this information.
    Thanks for the help.
    #7
    RISC
    Super Member
    • Total Posts : 5772
    • Reward points : 0
    • Status: online
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/24 09:29:04 (permalink)
    0
    Hi,
    I kind of remember that the issue was linked to ICSP pair 2 as you just mentioned. I exchanged with Microchip technical support at that time. What you just observed seems in line with what I remember. 
    Regards 

    For support make sure to check first here : http://microchipdeveloper.com
    There are hundreds of PIC, AVR, SAM...which one do YOU use ?
    #8
    Kartha
    New Member
    • Total Posts : 22
    • Reward points : 0
    • Joined: 2017/07/14 21:44:40
    • Location: 0
    • Status: offline
    Re: PIC24FG64GA702 Takes long time to complete programming. 2020/06/24 10:05:23 (permalink)
    0
    Ok, So seems no solution right? Any way it eats up a lot of development time.
    Please specify if there is any workaround.
    Thanks for your support.
    #9
    Jump to:
    © 2020 APG vNext Commercial Version 4.5