• AVR Freaks

Hot!RN4870 cannot enter Command Mode

Author
WeHongKongers
Super Member
  • Total Posts : 229
  • Reward points : 0
  • Status: offline
2020/06/23 04:31:53 (permalink)
0

RN4870 cannot enter Command Mode

Hello,
I am developing a PIC-BLE Board
https://www.microchip.com/DevelopmentTools/ProductDetails/DT100112
 
Then, I follow RN4870 user guide and try to enter its Command Mode but it does not respond after 3 dollar sign.
 
Could any one show me some tips to make it work?
 

Attached Image(s)

#1

5 Replies Related Threads

    ric
    Super Member
    • Total Posts : 28003
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: RN4870 cannot enter Command Mode 2020/06/23 04:43:45 (permalink)
    0
    How are you sending the "$$$" ?
    In particular, are you making sure there is nothing sent immediately before or after it?
    In particular, it must NOT be immediately followed by a CR or CRLF.
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #2
    WeHongKongers
    Super Member
    • Total Posts : 229
    • Reward points : 0
    • Status: offline
    Re: RN4870 cannot enter Command Mode 2020/06/23 04:49:44 (permalink)
    0
    Hello RIC,
    I simply press SHIFT and then press $ 3 times, as shown in my screenshot.
    #3
    WeHongKongers
    Super Member
    • Total Posts : 229
    • Reward points : 0
    • Status: offline
    Re: RN4870 cannot enter Command Mode 2020/06/23 04:59:32 (permalink)
    0
    I started a clean session and simply pressed SHIFT and then $ 3 times. Yet, nothing happened.
     
    Should I update RN4870's firmware first?  How do I do this?
     
    #4
    WeHongKongers
    Super Member
    • Total Posts : 229
    • Reward points : 0
    • Status: offline
    Re: RN4870 cannot enter Command Mode 2020/06/23 05:06:02 (permalink)
    0
    Strange error message received.
     

    Attached Image(s)

    #5
    WeHongKongers
    Super Member
    • Total Posts : 229
    • Reward points : 0
    • Status: offline
    Re: RN4870 cannot enter Command Mode 2020/06/23 13:27:58 (permalink)
    0
    The MPLAB IDE simple terminal does not work.
     
    I switched to Tera Term and everything worked.
     
    #6
    Jump to:
    © 2020 APG vNext Commercial Version 4.5