• AVR Freaks

Hot!TCP retransmission timeout with ATWINC1500 WiFi chip

Author
riwo_rens
New Member
  • Total Posts : 18
  • Reward points : 0
  • Joined: 2020/04/02 10:34:42
  • Location: 0
  • Status: offline
2020/05/28 05:34:21 (permalink)
0

TCP retransmission timeout with ATWINC1500 WiFi chip

Hello all,
 
I'm currently facing a problem with a TCP stack that sometimes continuously goes into its retransmission timeout (TCP_IP_START_TIMEOUT_VAL) and causing delay on the network.
 
Some background:
 
The project involves a PIC32MX795F512L and we're using an ATWINC1500 WiFi chip for the wireless communication. This problem was already posted before on the TCP/IP forum (my apologies if this is seen as a duplicate): https://www.microchip.com/forums/m1134366.aspx
 
After some trying, the project was ported to an ethernet starter kit to see if the problem was indeed in the TCP/IP stack. This turned out not to be the case as the communication has been fine after some days and several reboots.
 
This led me to believe that the problem may be in the WiFi driver or with the interface to the ATWINC1500 chip. Hence the reason for posting on this forum as well.
 
My harmony configuration for the WiFi driver can be seen in the attached image.
 
Please let me know if you need more information, I would be happy to supply.
 
#1
aschen0866
Super Member
  • Total Posts : 4573
  • Reward points : 0
  • Joined: 2006/01/08 22:18:32
  • Location: San Diego
  • Status: offline
Re: TCP retransmission timeout with ATWINC1500 WiFi chip 2020/05/28 08:32:30 (permalink)
5 (1)
The WINC1500 runs its own TCP/IP stack on the chip. I don't think your experience with the Harmony TCP/IP stack applies.
#2
Jump to:
© 2020 APG vNext Commercial Version 4.5