• AVR Freaks

Hot!FreeRTOS in MPLAB Harmony 3

Author
Erick S
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2020/05/18 17:43:19
  • Location: Germany
  • Status: offline
2020/05/19 03:39:00 (permalink)
0

FreeRTOS in MPLAB Harmony 3

Hello All,
 
I have been trying to generate code for FreeRTOS without success for a while now. Basically, no matter which other components I have active in the project, whenever I add the FreeRTOS component and try to generate code, Harmony Code Configurator gets stuck at 0% of the project generated. No errors, no messages displayed. I am attaching the picture to illustrate the step at which the tool gets stuck.
I am using MPLAB X IDE v5.20 and MPLAB 3 Harmony with the target being a PIC32MX795F512L. I have confirmed that the board works with FreeRTOS because I downloaded and executed the code from freertos.org.
 

Attached Image(s)

#1

2 Replies Related Threads

    arpananand
    Super Member
    • Total Posts : 498
    • Reward points : 0
    • Joined: 2009/11/18 04:35:42
    • Location: 0
    • Status: offline
    Re: FreeRTOS in MPLAB Harmony 3 2020/05/20 11:23:18 (permalink)
    5 (1)
    can you check your "console" window, it may have some error reported. also, you can attach your complete project here.
    #2
    optimus_jack
    Senior Member
    • Total Posts : 102
    • Reward points : 0
    • Joined: 2017/02/16 03:02:47
    • Location: 0
    • Status: offline
    Re: FreeRTOS in MPLAB Harmony 3 2020/05/20 20:10:33 (permalink)
    0
    Hi,
    Hope you cloned https://github.com/Microchip-MPLAB-Harmony/CMSIS-FreeRTOS into your harmony 3 folder.
    also please check the console window as suggested above to look for errors
     
    Example developed on this device --> https://github.com/Microc...ware/pic32mx_eth_sk2.X
    #3
    Jump to:
    © 2020 APG vNext Commercial Version 4.5