• AVR Freaks

Hot!I can't get started with the Curiosity LPC board with PIC16F18446 on-board.

Author
nashsth
New Member
  • Total Posts : 13
  • Reward points : 0
  • Joined: 2020/03/17 21:13:03
  • Location: 0
  • Status: offline
2020/05/05 09:09:20 (permalink)
0

I can't get started with the Curiosity LPC board with PIC16F18446 on-board.

Hi all,
I am having trouble working with this development board. I followed the instructions found here
however my board still isn't working.
 
I create a new project on MPLAB X IDE (v5.35):
New project --> Microchip Embedded --> Standalone project --> Device select: PIC16F18446 --> Select tool: Microchip kits; Curiosity/Starter Kits (PKON4) --> Compiler select: XC8 (v2.10) --> Give my project a name and save it.
 
Once I'm done with the above steps, it seems to be working fine, as seen in the "Project management window" (see the attached image with the same name): I can build projects, but when I try to program and run the device, I get the "PKOB4 Not Found" error (see the attached image with the same name).
 
Can anyone guide me on this issue?
 
Thank you everyone!

Attached Image(s)

#1

7 Replies Related Threads

    nashsth
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2020/03/17 21:13:03
    • Location: 0
    • Status: offline
    Re: I can't get started with the Curiosity LPC board with PIC16F18446 on-board. 2020/05/21 08:49:17 (permalink)
    1 (1)
    Bump....
    #2
    judd
    Starting Member
    • Total Posts : 43
    • Reward points : 0
    • Joined: 2019/04/15 22:30:22
    • Location: 0
    • Status: offline
    Re: I can't get started with the Curiosity LPC board with PIC16F18446 on-board. 2020/05/21 11:19:30 (permalink)
    0
    Well, does the kit appear in the device manager?
    #3
    RISC
    Super Member
    • Total Posts : 5607
    • Reward points : 0
    • Status: offline
    Re: I can't get started with the Curiosity LPC board with PIC16F18446 on-board. 2020/05/21 11:51:19 (permalink)
    0
    Hi,
    There are some issues with MPLAB X v5.35 and project properties. I got a patched JAVA file several weeks ago.
    But in the meantime MPLAB X  v5.40 has been released and I strongly recommend that you install it.
    My Curiosity (now called Curiosity LPC) has the old PKOB but you seem to have the new one (PKOB4) which is more powerful and integrated and include by default the Virtual COM Port (VCP).
    Regards
    #4
    nashsth
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2020/03/17 21:13:03
    • Location: 0
    • Status: offline
    Re: I can't get started with the Curiosity LPC board with PIC16F18446 on-board. 2020/05/21 17:32:59 (permalink)
    0
    RISC
    Hi,
    There are some issues with MPLAB X v5.35 and project properties. I got a patched JAVA file several weeks ago.
    But in the meantime MPLAB X  v5.40 has been released and I strongly recommend that you install it.
    My Curiosity (now called Curiosity LPC) has the old PKOB but you seem to have the new one (PKOB4) which is more powerful and integrated and include by default the Virtual COM Port (VCP).
    Regards




    Hi RISC,
     
    Thank you for your response. I downloaded the most recent MPLABX IDE (v5.40) and XC8 (v2.20) and it almost worked. However, I get a new error, as shown in the screenshot.
     
    Would you help me with this?
     
    Thank you,
    Nash

    Attached Image(s)

    #5
    nashsth
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2020/03/17 21:13:03
    • Location: 0
    • Status: offline
    Re: I can't get started with the Curiosity LPC board with PIC16F18446 on-board. 2020/05/21 17:36:53 (permalink)
    0
    Hi judd,
     
    Yes the PKOB4 appear in device manager, as shown in the screenshot. Another user recommended I download the most recent version of MPLAB, which is v 5.40. Upon downloading it and using it, I almost got the sample program to work, however I get a new error, as shown in the other screenshot attached to this post.
     
     

    Attached Image(s)

    #6
    nashsth
    New Member
    • Total Posts : 13
    • Reward points : 0
    • Joined: 2020/03/17 21:13:03
    • Location: 0
    • Status: offline
    Re: I can't get started with the Curiosity LPC board with PIC16F18446 on-board. 2020/05/22 06:16:53 (permalink)
    4 (1)
    Okay now it seems to work. I didn't do anything different today, but the "transmission on endpoint 2" error is no longer there.
    #7
    RISC
    Super Member
    • Total Posts : 5607
    • Reward points : 0
    • Status: offline
    Re: I can't get started with the Curiosity LPC board with PIC16F18446 on-board. 2020/05/26 08:35:19 (permalink)
    0
    Hi,
    It seems it initially failed to update the firmware but as you probably retried, it finally managed to do it.
    This is necessary every time a debugger / programmer is used with a new version of MPLAB X 
    Regards
    #8
    Jump to:
    © 2020 APG vNext Commercial Version 4.5