• AVR Freaks

Hot!Simulator throws java.lang.NullPointerException when stepping through asm code

Author
Foil
New Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2006/08/13 10:35:02
  • Location: 0
  • Status: offline
2020/04/07 13:31:21 (permalink)
0

Simulator throws java.lang.NullPointerException when stepping through asm code

Using MPLABX V5.30 on a Win10 HP laptop, I have problems getting the simulator to work.
 
It used to work at one point in time, but now fails, and I have tried to reinstall and also delete cache folder without luck.
Looking at error message it seems related to Java.
 
I have a simple PIC18F26K40 asm test project, and at this point I only want to use the simulator to verify the timing on some routines.
 
I click "Debug project", the project builds successfully, and the simulator buttons appear.
The following line appears in a "call stack" tab that pops up at this point:
 
*** Software Call Stack is not supported. Defaulting to line at current PC location. Hardware Stack is supported. See PIC Memory views. *** 
 
If I click "Step into" to run the first instruction, the simulator buttons disappear, and in notifications tab there is an
unexpected exception message. When I select show and report problem, I get this:
 
java.lang.NullPointerException
at com.microchip.mplab.debugger.mdb.MdbDebugger.propertyChange(MdbDebugger.java:7114)
at java.beans.PropertyChangeSupport.fire(PropertyChangeSupport.java:335)
at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:327)
at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:263)
at org.netbeans.core.windows.RegistryImpl.doFirePropertyChange(RegistryImpl.java:329)
at org.netbeans.core.windows.RegistryImpl.access$100(RegistryImpl.java:69)
at org.netbeans.core.windows.RegistryImpl$1.run(RegistryImpl.java:170)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
[catch] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
 
 
Similar behaviour also happens on my Win10 desktop with the same MPLABX and the same project.
Furthermore, I have the same MPLABX setup at my work desktop, but on this machine the simulator works
fine with this same project, which is shared on Dropbox.
 
Does anyone have a clue what can be done to fix this rarity?
 
Thanks in advance for any help.
 
 
#1

2 Replies Related Threads

    GeorgePauley
    Moderator
    • Total Posts : 1238
    • Reward points : 0
    • Joined: 2009/12/01 13:59:30
    • Location: Chandler AZ
    • Status: offline
    Re: Simulator throws java.lang.NullPointerException when stepping through asm code 2020/04/08 08:21:40 (permalink)
    0
    You'll have to call Microchip Tech Support and open a ticket on this.

    I'm pretty sure they will start by having you upgrade to MPLAB X 5.35.  So you might as well do that ahead of contacting Microchip.  There's a reasonable chance the problem doesn't exist in 5.35.
    #2
    Foil
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2006/08/13 10:35:02
    • Location: 0
    • Status: offline
    Re: Simulator throws java.lang.NullPointerException when stepping through asm code 2020/04/08 10:49:50 (permalink)
    0
    Problem still persists in V5.35.
     
    I will try and take this further with Microchip.
     
    #3
    Jump to:
    © 2020 APG vNext Commercial Version 4.5