• AVR Freaks

Helpful ReplyHot!No Power settings availale for PICkit3 in IPE 5.35

Author
Madmanguruman
New Member
  • Total Posts : 17
  • Reward points : 0
  • Joined: 2013/05/03 08:21:25
  • Location: 0
  • Status: offline
2020/03/09 07:18:50 (permalink)
0

No Power settings availale for PICkit3 in IPE 5.35

Recently upgraded from IDE/IPE 5.00 to 5.35.
 
In IPE, for PICkit3 there are no longer any power settings visible under the Power menu in advanced mode. Verified with multiple PICkit3s.
 
If I unplug the PICkit3 from the USB cable, power settings magically reappear. Once I reconnect, they disappear.
 
We rely on PICkit3 supplying power to our small boards when programming/testing on our benches so this is a huge issue for us.
 
 

Attached Image(s)

#1
ric
Super Member
  • Total Posts : 26942
  • Reward points : 0
  • Joined: 2003/11/07 12:41:26
  • Location: Australia, Melbourne
  • Status: online
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/03/09 12:41:31 (permalink)
0
You can keep multiple versions of MPLABX installed.
Just use the 5.00 version IPE until Microchip get this fixed.
 

I also post at: PicForum
Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
NEW USERS: Posting images, links and code - workaround for restrictions.
To get a useful answer, always state which PIC you are using!
#2
Madmanguruman
New Member
  • Total Posts : 17
  • Reward points : 0
  • Joined: 2013/05/03 08:21:25
  • Location: 0
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/03/09 12:56:00 (permalink)
0
Would love to but my laptop only has a 500GB SSD and even IPE standalone is bloatworthy - barely have room for a few versions of XC16.
#3
tech24x7
Starting Member
  • Total Posts : 90
  • Reward points : 0
  • Joined: 2013/10/14 21:38:52
  • Location: 0
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/03/09 21:09:25 (permalink)
0
Hi,
Seems there is an issue with PK3 in v5.35,  you can use it with v5.30 also
you can just install IPE with only selected architecture say 16bit option which will help you to say some disk space.
#4
Madmanguruman
New Member
  • Total Posts : 17
  • Reward points : 0
  • Joined: 2013/05/03 08:21:25
  • Location: 0
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/03/10 05:41:44 (permalink) ☄ Helpfulby LamdaElectronics 2020/04/28 04:33:44
0
By unplugging PICkit3 and playing with the non-device-specific power settings I was able to "glitch" the programmer power feed on. I wonder about MCHP's software QA practices, this seems like a pretty fundamental issue with the software and I can't imagine them not testing such a widely available programmer - not all of us have replaced our tens (or hundreds) of PK3s for 4s...
#5
PabloBalderrama
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/03/31 19:38:54
  • Location: 0
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/01 14:52:34 (permalink)
0
Hi, I've the same problem with my Pickit 3. How did you get to "glitch" the IPE? I cannot find any option which includes 'non-device-specific power'. Could you give me a hand with that? 
Thank you
 
#6
Madmanguruman
New Member
  • Total Posts : 17
  • Reward points : 0
  • Joined: 2013/05/03 08:21:25
  • Location: 0
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/02 07:59:28 (permalink)
0
I unplugged the PICkit3, went into power settings then saw that external power was enabled. Then I reconnected the PICkit3 and the power seemed to be on. Let me know if this works for you as well.
#7
PabloBalderrama
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/03/31 19:38:54
  • Location: 0
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/02 12:22:05 (permalink)
0
No.. It didn't work for me. I don't know what could have gone wrong with this new version of MPLAB. I can upload .hex files to the PIC but I have to use another power source, really annoying but I'll have to deal with it for the time. Thanks for the help!
#8
LamdaElectronics
Assembly_For_Ever
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2010/07/23 04:04:41
  • Location: Hellas-Greece
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/28 05:09:25 (permalink)
0
To the MPLABX programmers, please listen to the song and do EXACTLY as it says: "U Can't Touch This": https://www.youtube.com/watch?v=otCpCn0l4Wo
It is difficult for a programmer not to fiddle with "everything", but you are getting from one failure to another!
The other conspiracy theory I've heard is that Microchip is destroying every programming tool they have, to promote the 3rd party suppliers. 
PS. 
Madmanguruman
 
Finally your method does not work! If you try to connect to a board the response is: <<PICkit 3 is trying to supply 5,500000 volts from the USB port, but the target VDD is measured to be 4,750000 volts. This could be due to the USB port power capabilities or the target circuitry affecting the measured VDD.>>
Go Back to MPLAB IDE v.8.92 (the last working version) to get your programs work again!!



 
#9
LamdaElectronics
Assembly_For_Ever
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2010/07/23 04:04:41
  • Location: Hellas-Greece
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/28 05:33:00 (permalink)
0
To the Moderator: The Edit selection on the bottom left DOES NOT work. Do the honest thing and REMOVE IT!  
 
post edited by LamdaElectronics - 2020/04/29 01:40:02
#10
mbrowning
USNA79
  • Total Posts : 1741
  • Reward points : 0
  • Joined: 2005/03/16 14:32:56
  • Location: Melbourne, FL
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/28 06:39:57 (permalink)
0
1 - there's no moderation here at all unfortunately so save your energy.
2 - edit works fine if you follow the carefully hidden rules
Here is a good start:
https://www.microchip.com/forums/m1043667.aspx
Expressions which trigger the firewall
But I think your problem might be trying to edit a post with an active link. You have to break the link. It will be relinked once you hit submit.
#11
LamdaElectronics
Assembly_For_Ever
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2010/07/23 04:04:41
  • Location: Hellas-Greece
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/29 00:51:26 (permalink)
0
Thank you mbrowing, that's exactly what I'll do: I will save time and energy! I've wasted 30 minutes trying to decipher the "carefully hidden rules". So, will never use the edit, no problem! <- Finally I found it (obviously). I will send the simple directions to another post (As it shows it does not work to ALL of my posts! Sorry! Direct your complaints to the Microchip Programmers Geniuses)
The real Problem is the one revealed from Madmanguruman: "No Power settings available for PICkit3 in IPE 5.35"
Unfortunately the solution proposed by him does not work (for my boards at least!). Even IPE v. 5.20 has problems with my boards using the  PIC18F24k22! I've managed to program my boards (without an external power supply - just the board) only with the IPE v. 5.05. And YES I have 5 versions of MPLABX on my computer, and I have sent to the red my operating system disk (SSD). 
post edited by LamdaElectronics - 2020/04/29 01:45:26
#12
LamdaElectronics
Assembly_For_Ever
  • Total Posts : 77
  • Reward points : 0
  • Joined: 2010/07/23 04:04:41
  • Location: Hellas-Greece
  • Status: offline
Re: No Power settings availale for PICkit3 in IPE 5.35 2020/04/29 01:31:34 (permalink)
0
If you want to EDIT your own post, follow this procedure:
1. Select "POSTS"
2. Then "My Posts"
3. Then "View More" 
4. Then Select the desired Post
5. Make the changes
6. Select "Save Changes"


 
 

Attached Image(s)

#13
Jump to:
© 2020 APG vNext Commercial Version 4.5