• AVR Freaks

Hot!PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3

Author
Rob_CJ
New Member
  • Total Posts : 14
  • Reward points : 0
  • Joined: 2017/10/22 01:11:36
  • Location: 0
  • Status: offline
2020/03/04 10:52:50 (permalink)
0

PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3

Hello,
I have a few samples of the PIC18F27Q43 but when I start IPE (using a Pickit3) and I select this PIC, I cannot press the 'Apply'  since the ball on the screen next to the right of the PIC Type turns red so I cannot select it.
I hoped it was fixed with the latest version from MPLABX 5.35 but it did not.
Any idea why I am able to select it?
Thanks
#1

9 Replies Related Threads

    Sudheer Herle
    Super Member
    • Total Posts : 425
    • Reward points : 0
    • Joined: 2012/03/30 05:41:29
    • Location: Bangalore ,India
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/04 21:54:10 (permalink)
    0
    I think PICKit4 would support that device. Microchip has stopped supporting new devices for programming with old tools.
    #2
    tech24x7
    Junior Member
    • Total Posts : 105
    • Reward points : 0
    • Joined: 2013/10/14 21:38:52
    • Location: 0
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/04 21:59:36 (permalink)
    0
    It seems there is no New device support for PK3 from v5.30 onward.
    Please use PICKIT 4 
     
    #3
    Daniel.ITA
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2016/03/14 02:39:20
    • Location: 0
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/05 00:43:12 (permalink)
    5 (1)
    Dear Sirs,
    same matter with PICKIT3 on PIC18F67K22 which isn't a new MCU. Both IPE and IDE in debbuging get a programming error @ address 14000. Reverting to MPLABX Version 5.05 everything goes fine.
    What happen with V5.35?
    My customers have pickit3 to manage special programs and updating, I wouldn't let them change all for pickit4.
    I have 4pcs PICKIT3 in the company too, why should I change everything? It looks as the Apple's nightmare.
     
    Regards.
    Daniel
    #4
    Rob_CJ
    New Member
    • Total Posts : 14
    • Reward points : 0
    • Joined: 2017/10/22 01:11:36
    • Location: 0
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/05 11:14:14 (permalink)
    0
    Hello all,
    Is it somewhere officially mentioned that PicKit3 is no longer supported from V5.30 onwards? It still works for V5.30 with a PicKit 3 but only for this device it does not seem to work. Also I do not understand why it should no longer work since I do not think the programming specification deviates that much but I may be wrong of course.
    Thanks.
    #5
    Daniel.ITA
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2016/03/14 02:39:20
    • Location: 0
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/05 13:05:41 (permalink)
    5 (1)
    Dear Sirs,
    the point isn't no support for new chip.. this is accetable in my opinion, but to having troubles on old device fully supported till yesterday. This last options doesn't sound good to me.
    I saw that: Once installed V5.35, first time you try to use IPE it downloads the operative system into the pickit3.. and this stop working with PIC18F67K22 (programming error at address 0x14000).
    Than when I recover V5.05 it also re-updates the operative system into the pickit3, and this restart working fine.
    I can't try the cross test, since no way to avoid the new version IPE updates the pickit3.
    Anyway it's clear there's something in the new OS or in the new IPE which create troubles.
    I hope Microchip will resolve.
    "Please pass to pickit4 for old device too" it wouldn't be a good reply.
     
    Daniel
    #6
    ric
    Super Member
    • Total Posts : 28994
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/05 14:00:40 (permalink)
    0
    MPLAB 5.30 had massive problems earlier this week due to a screwup on the Microchip web server.
    It might work better now if you try it again.
    See: https://www.microchip.com/forums/m1130599.aspx

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #7
    tech24x7
    Junior Member
    • Total Posts : 105
    • Reward points : 0
    • Joined: 2013/10/14 21:38:52
    • Location: 0
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/05 21:44:14 (permalink)
    0
    Rob_CJ
    Hello all,
    Is it somewhere officially mentioned that PicKit3 is no longer supported from V5.30 onwards? It still works for V5.30 with a PicKit 3 but only for this device it does not seem to work. Also I do not understand why it should no longer work since I do not think the programming specification deviates that much but I may be wrong of course.
    Thanks.



    Yes, It officially mentioned in the PK3 homepage. 
    https://www.microchip.com/Developmenttools/ProductDetails/PG164130#additional-summary
    The PICkit 3 is not recommended for new designs and no new device support will be added to it as of June 1, 2019. For new designs, please see the MPLAB PICKit 4.
     
     
    #8
    Daniel.ITA
    New Member
    • Total Posts : 4
    • Reward points : 0
    • Joined: 2016/03/14 02:39:20
    • Location: 0
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/06 06:48:09 (permalink)
    0
    tech24x7
    Rob_CJ
    Hello all,
    Is it somewhere officially mentioned that PicKit3 is no longer supported from V5.30 onwards? It still works for V5.30 with a PicKit 3 but only for this device it does not seem to work. Also I do not understand why it should no longer work since I do not think the programming specification deviates that much but I may be wrong of course.
    Thanks.



    Yes, It officially mentioned in the PK3 homepage. 
    https://www.microchip.com/Developmenttools/ProductDetails/PG164130#additional-summary
    The PICkit 3 is not recommended for new designs and no new device support will be added to it as of June 1, 2019. For new designs, please see the MPLAB PICKit 4.
     
     


    I think it's accetable on the NEW devices, but for the OLD should work, no jokes. It sounds too much as planned obsolescence. ICD module inside PIC18F67K22 didn't change, as well as the PICKIT3, so it's just a software matter.
    I hope Microchip will resolve this issue.
     
    #9
    NKurzman
    A Guy on the Net
    • Total Posts : 19039
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: PIC18F27Q43 cannot be programmed with IPE 5.35 using PicKit3 2020/03/06 07:05:34 (permalink)
    0
    tech24x7
    It seems there is no New device support for PK3 from v5.30 onward.
    Please use PICKIT 4  

    The thing that you can not buy until the middle of May?
    #10
    Jump to:
    © 2020 APG vNext Commercial Version 4.5