• AVR Freaks

Harmony v3 GLCD Setup

Author
Georgios
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/02/06 08:32:03
  • Location: 0
  • Status: offline
2020/02/11 03:30:24 (permalink)
0

Harmony v3 GLCD Setup

Hi Everyone ,
 
I am trying to interface a  PIC32mz2064DAR176 with the screen LCD Display (DMT050WVHTCMI-1C). I belive that I have managed to display layer0 (white colour) of the screen but I could not use any other graphics like labels or buttons when I am using the Graphics composer from the tools. 
I could not find the specific screen I am using, but have found that the PDA TM5000 has characteristics very similar to mine. The resolution was the same but I could not change the pixel clock value. I can change it in the  GLCD display driver but not in the GFX Core.
 
Can this affect my setup?
How Can I modify these values?
Is there anything else you can suggest to change?
You can find attached the xml generated from harmony framework (Just change the txt if you want to call it )
 
Thanks
 
Georgios
#1

2 Replies Related Threads

    MHGC
    Super Member
    • Total Posts : 238
    • Reward points : 0
    • Status: offline
    Re: Harmony v3 GLCD Setup 2020/02/11 09:35:27 (permalink)
    5 (1)
    Hi,
     
    There is a bug for the Pixel Clock value propagating to the GFX Core.  You can change the value in the GLCD component and it will propagate correctly to the generated driver. 

    If you wish to adjust the other display timing values, you should still be ale to do so via the Display Manager
    https://microchip-mplab-harmony.github.io/gfx/frames.html?frmname=topic&frmfile=00006.html
    #2
    Georgios
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2020/02/06 08:32:03
    • Location: 0
    • Status: offline
    Re: Harmony v3 GLCD Setup 2020/02/12 10:38:50 (permalink)
    0
    Hi permalink,
    Thank you for your suggestion.
     
    I generated the code from Harmony and I added the "Enable Demo mode " but when I attempt to compile it i found the following error :
     
    ../src/config/default/gfx/libaria/libaria_demo_mode.c:40:34: fatal error: system/time/sys_time.h: No such file or directory
    #include "system/time/sys_time.h"
    ^
     
    I know this file is generated by the system services TIME component however when i add this it doesn't generate code any more. i have tried to connect tmr1 tmr2, tmr9 and CORE_TIMER but i always get an error generating the code. can anyone tell me how i should be configuring the system services TIME component.
     
    Thanks
    #3
    Jump to:
    © 2020 APG vNext Commercial Version 4.5