• AVR Freaks

Hot!SAMR34 OTAA Failure

Author
gilbertoe
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/02/06 18:44:19
  • Location: 0
  • Status: offline
2020/02/10 18:05:49 (permalink)
0

SAMR34 OTAA Failure

Hi
I am using a SAMR34 Xplained Pro Evaluation Kit in AU915 band and I am experiencing several errors in the Join command. Some times the activation via OTAA is completed. So I assume DEVICE_ADDRESS, APPLICATION_SESSION_KEY and NETWORK_SESSION_KEY are all correct.
 
After some testing. It was found that the call back function of the join command retruns a value = 4, meaning LORAWAN_RADIO_BUSY. I did not find any information on this error.
 
Can some one help on this?
 
SAMR34 Xplained Pro Evaluation Kit
Microchip LoRaWAN Stack MLS_SDK_1_0_P_3 
LORAWAN MOTE APPLICATION
 
BR
Gilberto
 
 
#1

4 Replies Related Threads

    gilbertoe
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2020/02/06 18:44:19
    • Location: 0
    • Status: offline
    Re: SAMR34 OTAA Failure 2020/02/12 16:05:44 (permalink)
    0
    Any information? 
    #2
    ric
    Super Member
    • Total Posts : 26083
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: SAMR34 OTAA Failure 2020/02/12 17:10:07 (permalink)
    0
    It looks like there's not too many people here who have used that part.
    It may be best to lodge a "Support Ticket" via http://microchip.com/support
     
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #3
    SJM
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2019/12/10 03:25:04
    • Location: Yorkshire, UK
    • Status: offline
    Re: SAMR34 OTAA Failure 2020/02/17 11:58:35 (permalink)
    0
    Please see this post on the RAK wireless forum that might be of interest: https://forum.rakwireless.com/t/rak4260-node-eu868-downlink-reliability/1381?u=fishbeetle
     
    #4
    SJM
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2019/12/10 03:25:04
    • Location: Yorkshire, UK
    • Status: offline
    Re: SAMR34 OTAA Failure 2020/02/17 12:08:21 (permalink)
    0
    You say "the call back function of the join command returns a value = 4"
    The callback function in my demo code (MLS_SDK_1_0_P_0) looks like this:
    static void join_cb(bool status)
    It returns only a boolean - it seems your MLS_SDK_1_0_P_3 is different, can you let me know what
    your cb function definition looks like please.
    Steve.
     
    post edited by SJM - 2020/02/17 15:28:17
    #5
    Jump to:
    © 2020 APG vNext Commercial Version 4.5