• AVR Freaks

Hot!Programming PIC32MX350 with PICKIT4 fails

Author
Elmi79
Starting Member
  • Total Posts : 35
  • Reward points : 0
  • Joined: 2017/03/05 08:07:13
  • Location: 0
  • Status: online
2020/01/21 11:08:38 (permalink)
0

Programming PIC32MX350 with PICKIT4 fails

I try to program my PIC32MX350 with the PICKIT4. In general it seems to work as the MPLab-IDE detects the correct PIC-type. But then downloading fails with a strange error message:
 
The following memory area(s) will be programmed:
program memory: start address = 0x1d000000, end address = 0x1d0031ff
configuration memory
boot config memory

Script CalcCRC_PE failed with status Type = runScript, Script name = CalcCRC_PE, Status = 0x102
data: 0:0:0:0:

 
Any idea what this message means/causes and how it can be fixed to let it program correctly?
 
Thanks!
 
#1

5 Replies Related Threads

    NKurzman
    A Guy on the Net
    • Total Posts : 18266
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: Programming PIC32MX350 with PICKIT4 fails 2020/01/21 12:52:36 (permalink)
    4 (1)
    What Version of MPLabX?  The Latest is V5.30
    #2
    dan1138
    Super Member
    • Total Posts : 3343
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Programming PIC32MX350 with PICKIT4 fails 2020/01/21 12:56:06 (permalink)
    0

    Script CalcCRC_PE failed with status Type = runScript, Script name = CalcCRC_PE, Status = 0x102 data: 0:0:0:0:

    Looks like a Java error. Try a different version of MPLABX.
    #3
    Elmi79
    Starting Member
    • Total Posts : 35
    • Reward points : 0
    • Joined: 2017/03/05 08:07:13
    • Location: 0
    • Status: online
    Re: Programming PIC32MX350 with PICKIT4 fails 2020/01/21 23:00:28 (permalink)
    0
    I'm already running the latest version 5.3 of the MPLab IDE. Any idea where this CalcCR_PE script is located at?
     
    #4
    dan1138
    Super Member
    • Total Posts : 3343
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Programming PIC32MX350 with PICKIT4 fails 2020/01/22 00:12:11 (permalink)
    0
    All I have on hand is MPLABX v5.25, PIC32MX360F512L and the PICKit4.
     
    This is working for me.
    /* 
    *****************************************************

     
    Connecting to MPLAB PICkit 4...

    Currently loaded versions:
    Application version............00.05.14
    Boot version...................01.00.00
    Script version.................00.03.10
    Script build number............5aef1e175b
    Target voltage detected
    Target device PIC32MX360F512L found.
    Device Revision Id  = 0xB3

    Calculating memory ranges to program...

    Erasing...

    The following memory area(s) will be programmed:
    program memory: start address = 0x1d000000, end address = 0x1d0007ff
    configuration memory
    boot config memory

    Programming/Verify complete
    */

    I have a vague memory of CRC issues with MPLAB and some of the PIC32 devices.
     
    If you can try the down rev of MPLABX v5.25
    #5
    Elmi79
    Starting Member
    • Total Posts : 35
    • Reward points : 0
    • Joined: 2017/03/05 08:07:13
    • Location: 0
    • Status: online
    Re: Programming PIC32MX350 with PICKIT4 fails 2020/01/22 12:44:52 (permalink)
    0
    OK, going back to version 5.20 solved the problem. Thanks!
     
    #6
    Jump to:
    © 2020 APG vNext Commercial Version 4.5