• AVR Freaks

Can't initialize a Qapass 1602A LCD with PIC18F4620

Author
aven75
New Member
  • Total Posts : 1
  • Reward points : 0
  • Joined: 2020/01/17 11:23:03
  • Location: 0
  • Status: offline
2020/01/18 04:51:26 (permalink)
0

Can't initialize a Qapass 1602A LCD with PIC18F4620

Hi to everyone, I can't initialize a QAPASS 1602A LCD with a PIC18F4620, I always get square blocks on both lines. At the beginning I tought the LCD was broken so I got a new one but the outcome is the same. I use a logifind PIC 40 Mini develpment board connected to PC through a PICkit3, everything else is working fine on every port but not the LCD.

Thanks a lot for your help.
#1

1 Reply Related Threads

    ric
    Super Member
    • Total Posts : 25500
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: Can't initialize a Qapass 1602A LCD with PIC18F4620 2020/01/20 12:59:56 (permalink)
    +1 (1)
    Maybe look a bit closer around line#42 of your code?
    With no idea what your code does, or how fast your PC is running, or how you have connected the PIC to the LCD, how can we advise if any of those things has a problem?
    (Is the LCD an embedded part of this development board, or something you have added? Not everyone here knows intimate details of every development board...)
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #2
    Jump to:
    © 2020 APG vNext Commercial Version 4.5