• AVR Freaks

Hot!MPLAX 5.30 & ICD4

Author
Hotfoot
Super Member
  • Total Posts : 238
  • Reward points : 0
  • Joined: 2010/10/24 09:00:18
  • Location: Sacrameto CA
  • Status: offline
2019/12/14 13:58:52 (permalink)
5 (3)

MPLAX 5.30 & ICD4

MPLAB X 5.30
ICD4
PIC24HJ256GP610A
Windows 10 (64)
 
I had been using my older ICD3 and it was bullet proof (just wanted to pick up some speed)
I had purchased a ICD4 (then running MPLAB X 4.10) and the ICD4 connected and was working. I upgraded to MPLAB X 5.30  and the ICD4 would no longer program the device, when connected the ICD4 would pass the self test. The ICD4 would even read the device properly. But when I would try to program the device, I would get an error
"Erasing ...
verify failed. [config mem] 0xf80000, expected 0xcf , got 0xc5 
 
I tried everything , I reset the ICD4 several times, and set the setting to NOT update the firmware but that did not seem to work.
During my testing I would go back and try the ICD3 and every time I did it worked flawlessly
the firmware for the ICD3 is ICD3FW_015602.jam
 
The MPLAB X 5.30  ICD4 firmware is ICD4FW_000270.jam  <-- This does NOT work with the Part 
The MPLAB X 4.10  ICD4 firmware was ICD4FW_000148.jam 
So I copied the 2 files from MPLAB X 4.10   icd4armfiles.jar  &    icd4files.jar
removed the files from MPLAB X 5.30 (saving them ) and I placed the above files into the directories MPLAB X 5.30
Now I can erase , read, write , Seems to be working correctly. with the older firmware. (See photos ) 
 
 
 
 
 
 
 
 

Attachment(s)

Attachments are not available: Download requirements not met

Good Luck with your project !
I hope this helps
#1

8 Replies Related Threads

    LostInSpace
    Super Member
    • Total Posts : 297
    • Reward points : 0
    • Joined: 2016/03/11 22:47:59
    • Location: 0
    • Status: offline
    Re: MPLAX 5.30 & ICD4 2019/12/14 18:53:36 (permalink)
    0
    This is good information, thanks for sharing - In MPLAB there are settings that can be made for the ICD's such as to slow them down. Perhaps this may work.
     
    If I might suggest reporting this to the support folks, then at least they would know about it and it will help us all.
    #2
    Hotfoot
    Super Member
    • Total Posts : 238
    • Reward points : 0
    • Joined: 2010/10/24 09:00:18
    • Location: Sacrameto CA
    • Status: offline
    Re: MPLAX 5.30 & ICD4 2019/12/14 19:47:33 (permalink)
    0
    Yes Please do !
    Even though so far it has been working good, I'm more that skeptical that it will have some other issue down the road.

    Good Luck with your project !
    I hope this helps
    #3
    ric
    Super Member
    • Total Posts : 26078
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: MPLAX 5.30 & ICD4 2019/12/14 23:12:05 (permalink)
    +1 (1)
    Hotfoot
    Yes Please do !
    Even though so far it has been working good, I'm more that skeptical that it will have some other issue down the road.

    LostIn Space was asking you to do it, not offering to do it for you...
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #4
    Kabak
    Starting Member
    • Total Posts : 87
    • Reward points : 0
    • Joined: 2014/07/30 03:47:55
    • Location: 0
    • Status: offline
    Re: MPLAX 5.30 & ICD4 2019/12/18 08:00:57 (permalink)
    0
    Hi  could you be so kind and attach working icd4armfiles.jar  &  icd4files.jar
    to your post or upload them for other users.
     
    Thank you
    #5
    Hotfoot
    Super Member
    • Total Posts : 238
    • Reward points : 0
    • Joined: 2010/10/24 09:00:18
    • Location: Sacrameto CA
    • Status: offline
    Re: MPLAX 5.30 & ICD4 2019/12/19 14:02:37 (permalink)
    0
    This is the Path on my Machine
    c:>Program Files (x86)>Microchip>MPLABX >v5.30>mplab_platform>mplablibs>modules>ext
     
    System will not allow me to upload the files
    post edited by Hotfoot - 2019/12/19 21:16:00

    Good Luck with your project !
    I hope this helps
    #6
    Kabak
    Starting Member
    • Total Posts : 87
    • Reward points : 0
    • Joined: 2014/07/30 03:47:55
    • Location: 0
    • Status: offline
    Re: MPLAX 5.30 & ICD4 2019/12/20 03:18:00 (permalink)
    0
    OK
     
    I installed MPLABX 4.10
    post edited by Kabak - 2019/12/20 03:20:40
    #7
    RDS Cliff
    Junior Member
    • Total Posts : 64
    • Reward points : 0
    • Joined: 2016/09/23 11:50:05
    • Location: 0
    • Status: offline
    Re: MPLAX 5.30 & ICD4 2020/01/20 20:03:46 (permalink)
    +1 (1)
    Test post.
    Man, this sucks.  Keep getting:
     
    You don't have permission to access "http://www.microchip.com/forums/post.aspx?" on this server.
    Reference #18.86c70617.1579575957.4351e1e2
    post edited by RDS Cliff - 2020/01/20 20:07:02
    #8
    RDS Cliff
    Junior Member
    • Total Posts : 64
    • Reward points : 0
    • Joined: 2016/09/23 11:50:05
    • Location: 0
    • Status: offline
    Re: MPLAX 5.30 & ICD4 2020/01/20 20:10:42 (permalink)
    0
    I'm seeing the same or a similar problem to what you are seeing.  But a few other curiosities.  Processor is a PIC24FJ256GA610.  Has been working for a year with the ICD4
     
    Using MPLAB X v5.30, flashing a standalone build seems to work fine.
    Flashing a debug build after flashing a standalone build works fine.
    Flashing a debug build after a debug build results in the error message:
     
    Verify failed.  [ Pgm ] at 0x0, expected 0x00040100, got 0x00000000
    You have set the program speed to Normal. The circuit on your board may require you to slow the speed down. Please change the setting in the tool properties to low and try the operation again.
    Programming did not complete.
     
    Going back to MPLAB X v5.10 and the problem disappears.  I see the ICD4 being setup with different App and Script versions with the different versions of MPLAB X.
     
    Has tech support offered any clues or should I file a ticket too?
    #9
    Jump to:
    © 2020 APG vNext Commercial Version 4.5