• AVR Freaks

Hot!SOLVED ------- "Error - Device not specified. Use -p option to specify a device."

Author
red380sl@gmail.com
New Member
  • Total Posts : 10
  • Reward points : 0
  • Joined: 2019/05/31 05:56:55
  • Location: 0
  • Status: offline
2019/12/14 10:24:36 (permalink)
0

SOLVED ------- "Error - Device not specified. Use -p option to specify a device."

I am getting back into working with microcontrollers. I had an elective class in college on this subject as part of my Computer Science degree and get found I liked it. 
 
Since my elective class I updates my Debian Linux system and installed the latest version of MPLAB X (5.3). This install appears to broken right out of the box. I gives me the error when I hit the build button of ---> "Error - Device not specified. Use -p option to specify a device."
 
How do I fix this? 
 
<pre>
make -f nbproject/Makefile-default.mk SUBPROJECTS= .build-conf
make[1]: Entering directory '/home/walt/programming/PIC/learn.X'
make -f nbproject/Makefile-default.mk dist/default/production/learn.X.production.hex
make[2]: Entering directory '/home/walt/programming/PIC/learn.X'
"/home/walt/Applications/mplabx/mpasmx/mpasmx" -q -p16f887 -u -l\"build/default/production/p0.lst\" -e\"build/default/production/p0.err\" -o\"build/default/production/p0.o\" \"p0.asm\"
make[2]: *** [dist/default/production/learn.X.production.hex] Error 1
make[1]: *** [.build-conf] Error 2
make: *** [.build-impl] Error 2
"/home/walt/Applications/mplabx/mpasmx/mplink" -w -m"dist/default/production/learn.X.production.map" -z__MPLAB_BUILD=1 -odist/default/production/learn.X.production.cof build/default/production/p0.o
MPLINK 5.09, LINKER
Device Database Version 1.49
Copyright (c) 1998-2011 Microchip Technology Inc.
Error - Device not specified. Use -p option to specify a device.
Errors : 1
nbproject/Makefile-default.mk:125: recipe for target 'dist/default/production/learn.X.production.hex' failed
make[2]: Leaving directory '/home/walt/programming/PIC/learn.X'
nbproject/Makefile-default.mk:91: recipe for target '.build-conf' failed
make[1]: Leaving directory '/home/walt/programming/PIC/learn.X'
nbproject/Makefile-impl.mk:39: recipe for target '.build-impl' failed
BUILD FAILED (exit value 2, total time: 310ms)
</pre>
post edited by red380sl@gmail.com - 2019/12/16 08:00:17
#1

4 Replies Related Threads

    NKurzman
    A Guy on the Net
    • Total Posts : 18852
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: MPLAB X on Linux. "Error - Device not specified. Use -p option to specify a device." 2019/12/14 10:51:47 (permalink)
    0
    Did you select a pic for the project ?
    #2
    crennolet
    Super Member
    • Total Posts : 202
    • Reward points : 0
    • Joined: 2012/03/15 09:51:58
    • Location: 0
    • Status: offline
    Re: MPLAB X on Linux. "Error - Device not specified. Use -p option to specify a device." 2019/12/14 12:20:50 (permalink)
    +2 (2)
    Apparently you are using a pic16f887 and doing an assembly project. I just created one and built it with no problem under Debian. So the problem appears to be specific to your installation.
     
    You seem to have installed mplabx in a nonstandard directory. While, in theory, installers should take care of all this for you, in practice Finagle's law makes installing to a nonstandard directory very iffy. If you must install it there, I suggest that you create a symbolic link in the standard location, "/opt/microchip/" (as in, log in as root and cd to /opt, and do a "ln -s [where you put mplab, mpasm, etc, looks like "/home/walt/Applications"] microchip") -- oh, and beware my dyslexia here...
     
    -- or just delete it and install it in the default location, try it, and get back to us.
     
    #3
    red380sl@gmail.com
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2019/05/31 05:56:55
    • Location: 0
    • Status: offline
    Re: MPLAB X on Linux. "Error - Device not specified. Use -p option to specify a device." 2019/12/15 12:44:09 (permalink)
    0
    crennolet
    Apparently you are using a pic16f887 and doing an assembly project. I just created one and built it with no problem under Debian. So the problem appears to be specific to your installation.
     
    You seem to have installed mplabx in a nonstandard directory. While, in theory, installers should take care of all this for you, in practice Finagle's law makes installing to a nonstandard directory very iffy. If you must install it there, I suggest that you create a symbolic link in the standard location, "/opt/microchip/" (as in, log in as root and cd to /opt, and do a "ln -s [where you put mplab, mpasm, etc, looks like "/home/walt/Applications"] microchip") -- oh, and beware my dyslexia here...
     
    -- or just delete it and install it in the default location, try it, and get back to us.
     


    I will reinstall it to the default location and give that a whirl. 


    Thanks
    post edited by red380sl@gmail.com - 2019/12/16 08:04:04
    #4
    red380sl@gmail.com
    New Member
    • Total Posts : 10
    • Reward points : 0
    • Joined: 2019/05/31 05:56:55
    • Location: 0
    • Status: offline
    Re: MPLAB X on Linux. "Error - Device not specified. Use -p option to specify a device." 2019/12/16 08:03:20 (permalink)
    0
    Thank you crennolet. That did the trick. 
     
    MPLAB X needs to install where it wants to be installed for it to function correctly.
     
    W.
    #5
    Jump to:
    © 2020 APG vNext Commercial Version 4.5