• AVR Freaks

Hot!MAC OS Catalina 10.15 support patch

Author
DevMod1
Administrator
  • Total Posts : 486
  • Reward points : 0
  • Joined: 2009/02/10 09:34:30
  • Location: 0
  • Status: offline
2019/12/11 10:26:26 (permalink)
5 (1)

MAC OS Catalina 10.15 support patch

We've just released a patch to allow macOS users to run MPLAB X IDE with Catalina 10.15 (removed 32-bit applications). The patch can be found on the MPLAB X IDE page, under the "Java® Platform and Operating System Direction" section here: https://www.microchip.com/mplab/mplab-x-ide
 

_____________________________

Please read the forum posting guidelines. Do not double post, please help keep these forums professional and comments respectful.
Please notify the moderators of problems/spam/trolls.
#1

4 Replies Related Threads

    agha
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2020/01/01 14:59:11
    • Location: 0
    • Status: offline
    Re: MAC OS Catalina 10.15 support patch 2020/01/03 07:25:00 (permalink)
    -1 (1)
    I cant install MPLAB X IDE 5.30 in macOS Catalina 10.15.2 with patch or without patch.
    Can you know what problem is?
    #2
    ric
    Super Member
    • Total Posts : 25632
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: MAC OS Catalina 10.15 support patch 2020/01/06 12:37:13 (permalink)
    +1 (1)
    agha
    I cant install MPLAB X IDE 5.30 in macOS Catalina 10.15.2 with patch or without patch.
    Can you know what problem is?

    https://www.microchip.com/forums/m1123391.aspx
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #3
    dobrosoft
    Starting Member
    • Total Posts : 51
    • Reward points : 0
    • Joined: 2019/05/20 04:44:55
    • Location: 0
    • Status: offline
    Re: MAC OS Catalina 10.15 support patch 2020/02/14 08:12:01 (permalink)
    +1 (1)
    On your webpage with patch download link is wrotten:
    Important Note for macOS® Users: The latest version of macOS, 10.15 Catalina, removes support for 32-bit applications. This means that current versions of MPLAB X IDE (up to version 5.40) will not run on this operating system without a patch. While this patch allows for MPLAB X IDE to be compatible with the Catalina update, only the MPLAB XC8 compiler is currently compatible. The MPLAB XC16 and MPLAB XC32 compilers will be updated for compatibility in January.
     
    I need use XC32, and I didn't update to Catalina yet, because it is still incompatible. Update is important for me, because I develop for 
    Xcode too, and it needs Catalina. When Will be fixed XC16 and XC32. 
     
    #4
    mpgmike
    Super Member
    • Total Posts : 365
    • Reward points : 0
    • Joined: 2014/01/23 17:27:06
    • Location: NJ
    • Status: offline
    Re: MAC OS Catalina 10.15 support patch 2020/02/14 09:30:34 (permalink)
    +1 (1)
    XC16 v1.50 (current version) is 64-bit.  Still waiting on XC32.

    I don't need the world to know my name, but I want to live a life so all my great-grandchildren proudly remember me.
    #5
    Jump to:
    © 2020 APG vNext Commercial Version 4.5