• AVR Freaks

Hot!Urgent: MPLABX Java Errors Preventing Running

Author
acharnley
Super Member
  • Total Posts : 573
  • Reward points : 0
  • Joined: 2016/05/01 06:51:28
  • Location: 0
  • Status: offline
2019/12/05 14:56:03 (permalink)
0

Urgent: MPLABX Java Errors Preventing Running

Hi,

Running latest Fedora. The last MPLABX version that worked for me is the 4.x series. With 5.xx I'm getting the screenshot attached.

Things I've tried:

1. wiped both .mplab_ide/ipe home directories
2. wiped the /opt/microchip folder and reinstalled everything
3. replaced the sys/java folder from the 4.x into the 5.x location.

Now stuck. 

Cheers,

Andrew

Attachment(s)

Attachments are not available: Download requirements not met
#1

11 Replies Related Threads

    acharnley
    Super Member
    • Total Posts : 573
    • Reward points : 0
    • Joined: 2016/05/01 06:51:28
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/05 15:39:49 (permalink)
    0
    And IPE -
     
    java.lang.ClassNotFoundException: javafx.scene.Node
    at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
    at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:222)
    Caused: java.lang.ClassNotFoundException: javafx.scene.Node starting from ModuleCL@2149b7c6[com.microchip.mplab.ipe] with possible defining loaders [ModuleCL@27fee16[com.microchip.mplab.libs.xplained.communication]] and declared parents [ModuleCL@222aa08b[com.microchip.mplab.mdbcore.ConfigBitsChecker], ModuleCL@7801bd49[com.microchip.mplab.mdbcore.RealICETool], ModuleCL@186078ed[com.microchip.mplab.mdbcore.AtmelIceScripting], ModuleCL@39c29c57[org.openide.awt], ModuleCL@2a7731fe[org.openide.io], ModuleCL@3c47d8c2[com.microchip.mplab.mdbcore.ICD4Tool], ModuleCL@3caa336b[com.microchip.mplab.libs.packmanagerservice], ModuleCL@7f8727e[com.microchip.mplab.mdbcore.platformtool], ModuleCL@2d533460[com.microchip.mplab.mdbcore.PM3], ModuleCL@3d9288d5[com.microchip.mplab.util.observers], ...30 more]
    at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:224)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
    Caused: java.lang.NoClassDefFoundError: javafx/scene/Node
    at com.microchip.mplab.ipe.menu.view.ReadDeviceIDAction.getMenuPresenter(ReadDeviceIDAction.java:50)
    at org.openide.awt.DynaMenuModel.loadSubmenu(DynaMenuModel.java:101)
    at org.openide.awt.MenuBar$LazyMenu$MenuFolder.createInstance(MenuBar.java:808)
    at org.openide.loaders.FolderInstance.defaultProcessObjectsFinal(FolderInstance.java:888)
    at org.openide.loaders.FolderInstance$1R.run(FolderInstance.java:730)
    at org.openide.util.Task.run(Task.java:257)
    [catch] at org.netbeans.modules.openide.loaders.AWTTask.run(AWTTask.java:79)
    at org.netbeans.modules.openide.loaders.AWTTask$Processor.run(AWTTask.java:172)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
    at java.awt.EventQueue.access$500(EventQueue.java:97)
    at java.awt.EventQueue$3.run(EventQueue.java:709)
    at java.awt.EventQueue$3.run(EventQueue.java:703)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
    at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
    #2
    acharnley
    Super Member
    • Total Posts : 573
    • Reward points : 0
    • Joined: 2016/05/01 06:51:28
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/08 06:13:59 (permalink)
    0
    ^^ I really need this fixed as it's restricting development to a PK3 (4.xx)
    #3
    crosland
    Super Member
    • Total Posts : 2014
    • Reward points : 0
    • Joined: 2005/05/10 10:55:05
    • Location: Warks, UK
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/08 07:14:41 (permalink)
    0
    Raise a ticket with microchip. You would have had a response by now.
    #4
    dB4301
    New Member
    • Total Posts : 16
    • Reward points : 0
    • Joined: 2019/11/22 14:34:09
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/09 13:57:06 (permalink)
    +1 (1)
    Not sure if this is related, but my life took a downturn this morning when I updated Java RE. V1.8 update 231. It forced an uninstall of previous JREs. MPLABX install 5.3 on Windows 10.
    First I could no longer detect my ICD4. When I tried to re-install 5.3 (also have MPLAB X 5.0 installed) it was unable to complete the install due to an (unknown) JRE error. 5.0 still opens, but I seem to have lost all my compiler license references. I apologize if this is too far off target, but it is Java-related.
    #5
    ric
    Super Member
    • Total Posts : 27979
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/09 15:05:34 (permalink)
    0
    dbishop@hydroid.com
    Not sure if this is related, but my life took a downturn this morning when I updated Java RE. V1.8 update 231. It forced an uninstall of previous JREs. MPLABX install 5.3 on Windows 10.
    First I could no longer detect my ICD4. When I tried to re-install 5.3 (also have MPLAB X 5.0 installed) it was unable to complete the install due to an (unknown) JRE error. 5.0 still opens, but I seem to have lost all my compiler license references. I apologize if this is too far off target, but it is Java-related.

    Normally you shouldn't be touching the Java install in Windows 10.
    MPLABX uses its own private version of the JRE, not any versions you have installed in Windows.
    MPLABX is ONLY designed to work with the JRE version that came with it.
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #6
    dB4301
    New Member
    • Total Posts : 16
    • Reward points : 0
    • Joined: 2019/11/22 14:34:09
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/09 15:11:13 (permalink)
    0
    Hi ric,
    I blindly followed a JRE update for the computer (general update). I also installed an old 1.7V as well (in case that might have helped). Regardless (as you say), the MPLAB X is supposed to run a local version, but for some reason the installer can't seem to find the java files in the install folder.
    #7
    ric
    Super Member
    • Total Posts : 27979
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/09 15:44:00 (permalink)
    0
    Did you try just reinstalling MPLABX?

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #8
    dB4301
    New Member
    • Total Posts : 16
    • Reward points : 0
    • Joined: 2019/11/22 14:34:09
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/10 09:04:29 (permalink)
    0
    Hi ric,
     
    I tried re-installing MPLAB X 5.3 several times with different Java RE versions, but I have not yet also uninstalled my MPLAB 5.0. Since it doesn't seem to be working right now either, I will try killing them both and start over.
    #9
    acharnley
    Super Member
    • Total Posts : 573
    • Reward points : 0
    • Joined: 2016/05/01 06:51:28
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/11 04:00:10 (permalink)
    0
    In my case I don't have JRE installed at all, so it has to use the MPLABX provided version.
    #10
    dB4301
    New Member
    • Total Posts : 16
    • Reward points : 0
    • Joined: 2019/11/22 14:34:09
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/11 08:02:24 (permalink)
    0
    Hi acharnley,
     
    I was able to solve the problem by uninstalling all versions of MLAB X (5.0 and 5.3) selecting to forget ALL persistence directories, re-booted, then installed MPLAB X 5.3 and all is running now.
     
    Dan
    #11
    oliverb
    Super Member
    • Total Posts : 285
    • Reward points : 0
    • Joined: 2009/02/16 13:12:38
    • Location: 0
    • Status: offline
    Re: Urgent: MPLABX Java Errors Preventing Running 2019/12/11 08:41:12 (permalink)
    0
    I don't know if this is relevant but some time ago I had a problem MPLAB X install where IPECMD wouldn't run. I found out eventually that the "jdkloc" file path was written wrong. In my 5.10 install it is written with one trailling backslash (windows) and that works so I'm guessing the trailing slash was missing. At the time I wrote a complex batch file hack to launch ipecmd.jar, then found out I had been wasting my time as after fixing ipecmd it worked as it should.
     
    Back when I had the trouble I might have been using XP with manually installed Java?
    TLDR the java install path was slightly broken and needed fixing manually.
     
    #12
    Jump to:
    © 2020 APG vNext Commercial Version 4.5