• AVR Freaks

Helpful ReplyHot!I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib

Author
newboy
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2019/11/18 03:27:40
  • Location: 0
  • Status: offline
2019/11/18 21:15:41 (permalink)
0

I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib

Hi,
 
I can't open IPE, it shows error when opening:
 
Warning - could not install some modules:
com.jcraft.jzlib - org.netbeans.InvalidException: Netigso: C:\Program Files (x86)\Microchip\MPLABX\v5.15\mplab_platform\ide\modules\com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib
com.jcraft.jsch - org.netbeans.InvalidException: Netigso: C:\Program Files (x86)\Microchip\MPLABX\v5.15\mplab_platform\ide\modules\com-jcraft-jsch.jar: Not found bundle:com.jcraft.jsch     
 
What's the problem?
 

Attached Image(s)

#1
tech24x7
Junior Member
  • Total Posts : 105
  • Reward points : 0
  • Joined: 2013/10/14 21:38:52
  • Location: 0
  • Status: offline
Re: I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib 2019/11/19 23:51:58 (permalink)
0
Hi,
Can you clear the cache directory below and try again?
C:\Users\xxxx\AppData\Roaming\mplab_ipe\dev\
#2
tech24x7
Junior Member
  • Total Posts : 105
  • Reward points : 0
  • Joined: 2013/10/14 21:38:52
  • Location: 0
  • Status: offline
Re: I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib 2020/02/10 20:40:33 (permalink) ☄ Helpfulby SOTI_Dev 2020/10/19 15:12:57
0
Please try below steps,
  1. If you have admin rights to that machine, After clearing the cache can you try running IPE using Run As Administrator mode
  2. If step 1 doesn’t help please try the below steps,
    • Uninstall IPE
    •  Just Delete everything from cache directory
    • C:\Users\xyzuser\AppData\Local\mplab_ipe\Cache\dev\v5.30
    • C:\Users\ xyzuser \AppData\Roaming\mplab_ipe\dev\v5.30
  • After deleting just restart your machine.
  • Reinstall IPE
#3
ric
Super Member
  • Total Posts : 28947
  • Reward points : 0
  • Joined: 2003/11/07 12:41:26
  • Location: Australia, Melbourne
  • Status: offline
Re: I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib 2020/02/10 20:58:42 (permalink)
5 (2)
Note, this topic is from Nov last year, and the OP was using v5.15
They have not logged in since Nov-21, so I think they've given up.
 

I also post at: PicForum
Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
NEW USERS: Posting images, links and code - workaround for restrictions.
To get a useful answer, always state which PIC you are using!
#4
SOTI_Dev
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2020/05/04 15:59:55
  • Location: 0
  • Status: offline
Re: I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib 2020/10/19 15:12:03 (permalink)
4 (1)
I just ran into the same issue.  I had copied just the bare essential files from Program Files (x86)\Microchip\... to get the IPE GUI to run w/o needing to install the MPLAB v5.30 environment.  The goal was to get a production team to unpack a zip file and run the binary for the IPE without needing to use an installer.  I tested my bare-bones version from a random path on my drive, it worked fine.  I zipped up the folder tree and deleted the temporary folder.  Next time I tried to run the IPE from it's install location, I got the errors about not being able to find com.jcraft.jsch.jar and com.jcraft.jlib.jar despite the files still existing in the MPLAB default install location.  Re-installing didn't help, deleting the Roaming cache location didn't help but deleting the Local cache location fixed the problem.  That's an odd design choice to have the cached library locations override the default install locations if the software doesn't then fall back to check the default location when the cached location doesn't exist. 
 
Hope this helps someone else.
post edited by SOTI_Dev - 2020/10/19 15:14:40
#5
tech24x7
Junior Member
  • Total Posts : 105
  • Reward points : 0
  • Joined: 2013/10/14 21:38:52
  • Location: 0
  • Status: offline
Re: I can't open IPE: com-jcraft-jzlib.jar: Not found bundle:com.jcraft.jzlib 2020/10/20 01:26:55 (permalink)
0
Did you try open IPE GUI with admin rights?  Hope that solves the issue.
#6
Jump to:
© 2020 APG vNext Commercial Version 4.5