• AVR Freaks

Hot!PICKit4 Not Found

Author
cbwelch
New Member
  • Total Posts : 8
  • Reward points : 0
  • Joined: 2019/11/08 14:19:29
  • Location: 0
  • Status: offline
2019/11/15 17:33:24 (permalink)
0

PICKit4 Not Found

Hello.
 
I am a beginner to the microcontroller scene. XC8 v2.10, MPLAB v5.20, PIC16LF15313, PICKit4. When I plug the PICKit4 into my computer, the light comes on in standby mode. But everytime when I go to run/program my mc, it says that the PICKit4 is not found. Does anybody have an idea where to begin troubleshooting or how to solve this issue?
 
Much appreciated.
#1

6 Replies Related Threads

    NKurzman
    A Guy on the Net
    • Total Posts : 18061
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: PICKit4 Not Found 2019/11/15 19:12:15 (permalink)
    0
    https://www.microchip.com/cisar/Home.aspx

    But what OS is the on the computer?
    Direct connect or a hub?
    USB 2 or usb 3 port?
    Does the OS see it? Does it have a driver?
    #2
    cbwelch
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2019/11/08 14:19:29
    • Location: 0
    • Status: offline
    Re: PICKit4 Not Found 2019/11/15 19:15:56 (permalink)
    0
    macOS Mojave Version 10.14.5. Direct usb connection. Usb 3 port. OS sees the connect, but does not identify as PICKit4, identified as "Remote Disc".
     
    Thank you for your response.
    #3
    AMPS
    Super Member
    • Total Posts : 468
    • Reward points : 0
    • Status: offline
    Re: PICKit4 Not Found 2019/11/15 20:11:45 (permalink)
    0
    Can u send screenshot of Screen shot of Select tool option in mplab X ide V 5.20.weather when PICKIT4 connected hardware tool detect yellow or grey color.
     
    you can also try MPLAB X IPE .where you would know pickit4 is detected or not in tools section. it will be installed along with mplab X IDE. you can send screen shot of 
     
    post edited by AMPS - 2019/11/15 20:13:50

    Amps
    *.*.*.*.*.*.*.*.*.*.*.*.*
    #4
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 3370
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: PICKit4 Not Found 2019/11/15 20:16:05 (permalink)
    +1 (1)
    On my Motherboard USB3 does not work with any of the PicKits.
    USB2 works fine.

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #5
    NKurzman
    A Guy on the Net
    • Total Posts : 18061
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: PICKit4 Not Found 2019/11/15 21:35:04 (permalink)
    0
    Try a USB2 port if you have one.
    #6
    cbwelch
    New Member
    • Total Posts : 8
    • Reward points : 0
    • Joined: 2019/11/08 14:19:29
    • Location: 0
    • Status: offline
    Re: PICKit4 Not Found 2019/12/03 16:25:26 (permalink)
    0
    Hello,
     
    I have purchased a usb2 hub and my computer now recognizes the PICKit4, however when I try to run something on MPLAB IDE, it still says that the previous device is unable to be found. Help?
    #7
    Jump to:
    © 2019 APG vNext Commercial Version 4.5