• AVR Freaks

Hot!Curiosity PIC32MZEF Dev Board 2.0 - TARGET USB Port Not Working [SOLVED]

Author
BillP
Super Member
  • Total Posts : 389
  • Reward points : 0
  • Joined: 2014/09/28 07:53:35
  • Location: CA
  • Status: offline
2019/11/05 08:53:39 (permalink)
0

Curiosity PIC32MZEF Dev Board 2.0 - TARGET USB Port Not Working [SOLVED]

Has anyone been able to get the dev 2.0 board to communicate over the Target USB port?

I have a dev 1.0 board and my dual CDC app works fine on that board.  On the 2.0 board, using the same cables and MZ configuration, the Target USB port does not work.  I traced in debug mode and it appears the port is being reset approximately 2x/sec.  The light on my Belkin USB hub is blinking instead of being solid.  

Is there a configuration setting that is different on the 2.0 board?
BTW - there are no demo examples for this board.  Could it be a (shudder!) a hardware problem?


post edited by BillP - 2020/02/18 11:07:56
#1

2 Replies Related Threads

    SyeT
    Junior Member
    • Total Posts : 55
    • Reward points : 0
    • Joined: 2012/07/24 00:38:10
    • Location: 0
    • Status: offline
    Re: Curiosity PIC32MZEF Dev Board 2.0 - TARGET USB Port Not Working 2020/02/18 00:06:36 (permalink)
    0
    Hi,
     
    Please refer H3 examples on this board at
    https://www.microchip.com/DevelopmentTools/ProductDetails/PartNO/DM320209
     
    The above link has an example for USB. 
    #2
    BillP
    Super Member
    • Total Posts : 389
    • Reward points : 0
    • Joined: 2014/09/28 07:53:35
    • Location: CA
    • Status: offline
    Re: Curiosity PIC32MZEF Dev Board 2.0 - TARGET USB Port Not Working 2020/02/18 11:07:31 (permalink)
    5 (1)
    This problem is solved -- the USB clock on the Dev 2.0 board is 12 MHz (not 24 MHz as on the Dev 1.0 board).
     
    See https://www.microchip.com/forums/FindPost/1128761
    #3
    Jump to:
    © 2020 APG vNext Commercial Version 4.5