• AVR Freaks

Hot!Problems while using PICkit 4 with Ubuntu 18.04

Author
JosephPena
New Member
  • Total Posts : 5
  • Reward points : 0
  • Joined: 2017/08/06 16:04:05
  • Location: 0
  • Status: offline
2019/10/25 14:19:18 (permalink)
0

Problems while using PICkit 4 with Ubuntu 18.04

Hi, I'm using the following:
  • OS: Ubuntu 18.04
  • IDE: MPLAB X IDE v5.25
  • Programmer: PICkit 4
  • Microcontroller: ATtiny402
  • Power: External 3.3v power source
  • Protocol: UPDI
At first, I connect the PICkit 4  to my laptop and then turn on the power source. Then use the programming option ant all Ok. After a few times programming, the number of times is variable. The PICkit 4 doesn't appear anymore for the MPLAB. Then a box pops up (The content is attached to this publication).

If I press the "OK" option, the programming fails with the following output: "Failed to initialize tool"

So I disconnect and reconnect the PICkit 4 and continue working.

What should I do to avoid this problem or fix it?
 

Attached Image(s)

#1

1 Reply Related Threads

    Wanglesnap
    Starting Member
    • Total Posts : 33
    • Reward points : 0
    • Joined: 2019/01/30 10:40:15
    • Location: 0
    • Status: offline
    Re: Problems while using PICkit 4 with Ubuntu 18.04 2020/01/14 08:08:31 (permalink)
    0
    Rather a late answer but still :- I use the same OS and debugger ,change to the latest MPLABX and like myself all should be well. But you must change all include files to non-capitals as Linux is case sensitive.Look in opt/microchip/mplabx/v5.30/mpasmx/ or whatever version you use.
    #2
    Jump to:
    © 2020 APG vNext Commercial Version 4.5