• AVR Freaks

Hot!Could not find Generic linker commands for this device

Author
Designer
Super Member
  • Total Posts : 454
  • Reward points : 0
  • Joined: 2007/11/20 20:28:41
  • Location: 0
  • Status: offline
2019/10/21 16:49:13 (permalink)
0

Could not find Generic linker commands for this device

I use PIC16F716 in MPLAB 8.92.When I build the project it says "Error - Could not find Generic linker commands for this device. Errors : 1"  
How to overcome..!!

Attached Image(s)

#1

4 Replies Related Threads

    dan1138
    Super Member
    • Total Posts : 3287
    • Reward points : 0
    • Joined: 2007/02/21 23:04:16
    • Location: 0
    • Status: offline
    Re: Could not find Generic linker commands for this device 2019/10/21 17:12:28 (permalink)
    +2 (2)
    On my system it is located here: C:\Program Files (x86)\Microchip\MPLAB\MPASM Suite\LKR\16f716_g.lkr
     
    This is what my MPLAB v8.92 build output looks like:
    /*
    ----------------------------------------------------------------------
    Debug build of project `E:\public\PIC\16F\16F716\f1116046\16F716_asm.mcp' started.
    Language tool versions: MPASMWIN.exe v5.51, mplink.exe v4.49, mplib.exe v4.49
    Preprocessor symbol `__DEBUG' is defined.
    Mon Oct 21 17:13:44 2019
    ----------------------------------------------------------------------
    Clean: Deleting intermediary and output files.
    Clean: Deleted file "E:\public\PIC\16F\16F716\f1116046\main.o".
    Clean: Deleted file "E:\public\PIC\16F\16F716\f1116046\main.err".
    Clean: Deleted file "E:\public\PIC\16F\16F716\f1116046\main.lst".
    Clean: Deleted file "E:\public\PIC\16F\16F716\f1116046\16F716_asm.cof".
    Clean: Deleted file "E:\public\PIC\16F\16F716\f1116046\16F716_asm.hex".
    Clean: Deleted file "E:\public\PIC\16F\16F716\f1116046\16F716_asm.mcs".
    Clean: Done.
    Executing: "C:\Program Files (x86)\Microchip\MPLAB\MPASM Suite\MPASMWIN.exe" /q /p16F716 "main.asm" /l"main.lst" /e"main.err" /o"main.o" /d__DEBUG=1
    Executing: "C:\Program Files (x86)\Microchip\MPLAB\MPASM Suite\mplink.exe" /p16F716 "main.o" /u_DEBUG /z__MPLAB_BUILD=1 /z__MPLAB_DEBUG=1 /o"16F716_asm.cof" /M"16F716_asm.map" /W
    MPLINK 4.49, Linker
    Device Database Version 1.14
    Copyright (c) 1998-2011 Microchip Technology Inc.
    Errors    : 0

    MP2HEX 4.49, COFF to HEX File Converter
    Copyright (c) 1998-2011 Microchip Technology Inc.
    Errors    : 0

    Loaded E:\public\PIC\16F\16F716\f1116046\16F716_asm.cof.
    ----------------------------------------------------------------------
    Debug build of project `E:\public\PIC\16F\16F716\f1116046\16F716_asm.mcp' succeeded.
    Language tool versions: MPASMWIN.exe v5.51, mplink.exe v4.49, mplib.exe v4.49
    Preprocessor symbol `__DEBUG' is defined.
    Mon Oct 21 17:13:46 2019
    ----------------------------------------------------------------------
    BUILD SUCCEEDED
    */

    post edited by dan1138 - 2019/10/21 17:15:41
    #2
    ric
    Super Member
    • Total Posts : 24593
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: Could not find Generic linker commands for this device 2019/10/21 17:56:14 (permalink)
    +2 (2)
    I'd also be wary about using MPLAB8 on a project with spaces in the path.
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #3
    Designer
    Super Member
    • Total Posts : 454
    • Reward points : 0
    • Joined: 2007/11/20 20:28:41
    • Location: 0
    • Status: offline
    Re: Could not find Generic linker commands for this device 2019/10/22 01:04:31 (permalink)
    0
    Thanks.
    Anyway after opening another project using the same chip in MPLAB the linker problem got vanished.
    You mean to name my project without spaces..!!! 
    #4
    ric
    Super Member
    • Total Posts : 24593
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: offline
    Re: Could not find Generic linker commands for this device 2019/10/22 01:23:11 (permalink)
    +2 (2)
    Yes, no spaces in the project name.
    I'd also tend to put it in a folder without spaces in the path, so NOT in "My Documents" ...
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #5
    Jump to:
    © 2019 APG vNext Commercial Version 4.5