• AVR Freaks

ICD3 / Windows10 / code 10 error (driver prob)

Author
j2423
Super Member
  • Total Posts : 277
  • Reward points : 0
  • Joined: 2015/05/15 23:10:36
  • Location: 0
  • Status: offline
2019/10/08 20:56:20 (permalink)
0

ICD3 / Windows10 / code 10 error (driver prob)

Successfully connect to Pickit 3 from Windows 10 virtual environment (VirtualBox / OSX Catalina / latest MPLABX fresh installation).
 
ICD3 poses a problem. Windows 10 sees the device but get a driver error with a Code 10.
 
Any suggestions?
 
#1

2 Replies Related Threads

    paulmtcuk
    Starting Member
    • Total Posts : 43
    • Reward points : 0
    • Joined: 2007/08/23 05:16:51
    • Location: 0
    • Status: offline
    Re: ICD3 / Windows10 / code 10 error (driver prob) 2019/10/08 23:49:33 (permalink)
    0
    Just an obvious question - have you run the MPLAB driver switcher (as administrator) and chose MPLAB X then Apply?
     
    further instructions: https://microchipdeveloper.com/mplabx:switching-usb-drivers
     
    I assume you've also enabled the USB controller in VirtualBox and enabled in ICD3 in the Devices-->USB menu?
    post edited by paulmtcuk - 2019/10/08 23:52:57
    #2
    j2423
    Super Member
    • Total Posts : 277
    • Reward points : 0
    • Joined: 2015/05/15 23:10:36
    • Location: 0
    • Status: offline
    Re: ICD3 / Windows10 / code 10 error (driver prob) 2019/10/08 23:58:30 (permalink)
    0
    Good question.
    (Habitually an OSX user.)
     
    Turns out one can only use the driver switcher if one has MPLABB 8 installed as well - not my case.
     
    Windows 10 itself told me latest driver for the ICD 3 installed: normal because have only just installed MPLAB X.
     
    Thanks
    #3
    Jump to:
    © 2019 APG vNext Commercial Version 4.5