• AVR Freaks

dsPIC33EP512MU814 and USB, device has no VID/PID -- Solved, were wrong APLL Settings

Author
JPortici
Super Member
  • Total Posts : 777
  • Reward points : 0
  • Joined: 2012/11/17 06:27:45
  • Location: Grappaland
  • Status: offline
2019/09/26 01:26:41 (permalink)
0

dsPIC33EP512MU814 and USB, device has no VID/PID -- Solved, were wrong APLL Settings

EDIT: Keeping the text as reference, also because i can't delete threads.
It was just wrong configuration of the APLL, APLLPRE to be exact. I had to read that register description a zillion times before getting it right.
 
 
 
 
 
 
Hi, I need to get usb to work on a dsPIC33EP512MU814. (Going to be vendor but want to start with HID, baby steps.)
This MCU is not supported by MCC so please don't suggest to use it.
There are however a plethora of examples in the old MLA libraries, v2018, altough they are targeting the 810 (the 100 pin variant)
 
What i tried to do first was to copy the relevant stack files from the example to my firmware, also copied the application functions and inserted the required calls in the same places, but when i insert the usb plug the usb connected led comes on but windows shows a notification that it couldn't recognize the device.
 
If i go to see in device manager, both VID and PID are set to zero.
 
What i tried to do then was to copy the custom hid example and change the configuration to match my MCU and my hardware:
- I changed the MCU from 810 to 814
- I changed all the p33ep512mu810.h includes to xc.h
- I changed the oscillator configuration to match my hardware (16MHz crystal instead of 8MHz crystal)
- I changed the position of the USB led and the activity led according to my hardware
 
Compiled, programmed, same result.
 
What should i be looking for? Hardware issue perhaps?
 
 
Ah, i tried older versions of the MLA as well.. but they wouldn't even get me to fail to enumerate. They would do nothing at all.
 
post edited by JPortici - 2019/09/26 01:43:41
#1

0 Replies Related Threads

    Jump to:
    © 2019 APG vNext Commercial Version 4.5