• AVR Freaks

Unresolved inside include file?

Author
mouchuanlin
Starting Member
  • Total Posts : 56
  • Reward points : 0
  • Joined: 2019/01/23 12:41:10
  • Location: 0
  • Status: offline
2019/09/10 13:08:33 (permalink)
0

Unresolved inside include file?

Hi,
I am seeing the IDE shows some unresolved include file but compiler seems fine. See attached png file.
 
Any suggestions?
 
Thx
 
#include <xc.h>
  - this file is missing #include <xc8debug.h>
#include <string.h>
  - this file is missing #include <strings.h>
 
 

Attached Image(s)

#1

6 Replies Related Threads

    mlp
    boots too small
    • Total Posts : 966
    • Reward points : 0
    • Joined: 2012/09/10 15:12:07
    • Location: previously Microchip XC8 team
    • Status: offline
    Re: Unresolved inside include file? 2019/09/10 13:13:48 (permalink)
    +1 (1)
    mouchuanlin
    I am seeing the IDE shows some unresolved include file but compiler seems fine. See attached png file.
     
    Any suggestions?

    I suggest you ignore the complaints of the IDE when the compiler is happy with your source file.
    This is a long-standing problem with MPLAB X (search the forum for "red squiggly line"), and unlikely to be fixed in the short term.

    Mark (this opinion available for hire)
    #2
    mouchuanlin
    Starting Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2019/01/23 12:41:10
    • Location: 0
    • Status: offline
    Re: Unresolved inside include file? 2019/09/10 13:28:13 (permalink)
    0
    OK. Thx
    #3
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 4003
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: Unresolved inside include file? 2019/09/10 13:53:46 (permalink)
    0
    Options -> Embedded Settings -> Generic Settings
     
    Enable Silent Build
    ------- ------- -----
    Without a clean build, 3 lines displayed when successful.
     
    BUILD SUCCESSFUL (total time: 254ms)
    Loading code from C:/Users/Gort1951/MPLABXProjects/SLAVE_CORE.X/dist/default/production/SLAVE_CORE.X.production.hex...
    Loading completed
     
     
     

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #4
    Gort2015
    Klaatu Barada Nikto
    • Total Posts : 4003
    • Reward points : 0
    • Joined: 2015/04/30 10:49:57
    • Location: 0
    • Status: offline
    Re: Unresolved inside include file? 2019/09/10 14:10:39 (permalink)
    0
    "red squiggly lines"
    Remove or disable the spell-checker.
    It is not scanning your text for syntax, it is checking the spelling according to the installed language.
     
    long Sapce
    long Space

    MPLab X playing up, bug in your code? Nevermind, Star Trek:Discovery will be with us soon.
    https://www.youtube.com/watch?v=Iu1qa8N2ID0
    + ST:Continues, "What Ships are Made for", Q's back.
    #5
    mouchuanlin
    Starting Member
    • Total Posts : 56
    • Reward points : 0
    • Joined: 2019/01/23 12:41:10
    • Location: 0
    • Status: offline
    Re: Unresolved inside include file? 2019/09/11 11:15:28 (permalink)
    0
    I am very sure it's not spelling.
    #6
    mbrowning
    USNA79
    • Total Posts : 1796
    • Reward points : 0
    • Joined: 2005/03/16 14:32:56
    • Location: Melbourne, FL
    • Status: offline
    Re: Unresolved inside include file? 2019/09/11 12:24:04 (permalink)
    0
    I find the IDE's parsing of source code to be very useful, but it does often paint the screen with squiggles. Generally for me they clear up within a few seconds by saving all files and clicking somewhere within a text window.
     
    Occasionally I have to right click on the project name and select Code Assistance -> Reparse Project
     
    Many have complained that they are persistent, however. You can turn off the code hints by selecting under "Tools" menu, Editor - > Hints and turn off all or some.
     
    There have been other suggestions that I haven't needed to try. I think explicitly adding the include directories under Compiler options is one.
     
    edit - I also turned off the editor's spellchecker for C comments.
    post edited by mbrowning - 2019/09/11 12:25:35
    #7
    Jump to:
    © 2020 APG vNext Commercial Version 4.5