• AVR Freaks

Hot!16F753 DAC not functioning as expected.

Author
b4lamb
Starting Member
  • Total Posts : 30
  • Reward points : 0
  • Joined: 2006/12/30 10:56:49
  • Location: Wales UK
  • Status: offline
2019/09/09 08:13:08 (permalink)
0

16F753 DAC not functioning as expected.

I'm using a 16F753 with a 9 bit DAC.  I've configure Left justify and selected +5V Vdd as the Vsource+ and I'm loading DACREFL before DACREFH.
 As required. I'm getting a non linear output, more like exponential with increasing 9 bit ref values loaded moreover the maximum analogue output is only reaching 1.5 V with a value of FF80h loaded.  There is no electrical loading on DACxOUT1 pin.  I've tried using the internal Op amp peripherel in voltage follower (buffer) mode but this results in an even smaller output from the OP Amp and the unbuffered DAC output is unaffected when I configure the OP Amp.
 
I'm perplexed .... can it be that my device is faulty?  I don't have a replacement yet to try out.
 
 
post edited by b4lamb - 2019/09/09 08:16:19
#1

5 Replies Related Threads

    coffee critic
    Super Member
    • Total Posts : 392
    • Reward points : 0
    • Status: offline
    Re: 16F753 DAC not functioning as expected. 2019/09/09 08:48:35 (permalink)
    0
    Did you disconnect your programmer?

    n_*$
    #2
    b4lamb
    Starting Member
    • Total Posts : 30
    • Reward points : 0
    • Joined: 2006/12/30 10:56:49
    • Location: Wales UK
    • Status: offline
    Re: 16F753 DAC not functioning as expected. 2019/09/09 08:52:34 (permalink)
    0
    No to be fair I've not tried that.  I'll wizz over to my bench and try that.
    Thanks
     
    #3
    b4lamb
    Starting Member
    • Total Posts : 30
    • Reward points : 0
    • Joined: 2006/12/30 10:56:49
    • Location: Wales UK
    • Status: offline
    Re: 16F753 DAC not functioning as expected. 2019/09/09 09:00:41 (permalink)
    0
    Brilliant .... yes that works.  Why I did not try disconnecting my ICD 3 I do not know.  I'm surprised I've not read such warnings but I'm sure they are there staring me in the face if I re look.
     
    #4
    coffee critic
    Super Member
    • Total Posts : 392
    • Reward points : 0
    • Status: offline
    Re: 16F753 DAC not functioning as expected. 2019/09/09 09:40:30 (permalink)
    0
    Like R-M-W we usually only do this once.

    n_*$
    #5
    b4lamb
    Starting Member
    • Total Posts : 30
    • Reward points : 0
    • Joined: 2006/12/30 10:56:49
    • Location: Wales UK
    • Status: offline
    Re: 16F753 DAC not functioning as expected. 2019/09/09 10:20:22 (permalink)
    0
    Yes exactly, Thank you very much for your help, I've put it in bold in my source code Notes so others picking my code are suitably warned.
    I cannot get the internal OP amp to work as a voltage follower mind but as I need to amplify the DAC output to achieve a 0 to 10 V signal anyway I'll use an external R-R op amp which will present a high impedance input to the DAC output pin.
     
    Cheers
    John 
    #6
    Jump to:
    © 2020 APG vNext Commercial Version 4.5