• AVR Freaks

Hot!Harmony Configuration 3 failed to create plugin

Author
RyanF
New Member
  • Total Posts : 7
  • Reward points : 0
  • Joined: 2017/04/11 06:31:29
  • Location: 0
  • Status: offline
2019/09/05 06:32:19 (permalink)
0

Harmony Configuration 3 failed to create plugin

Hello
I am trying to set up Harmony 3 on my system (all work to date has been Harmony 2.06)
 
I have installed MHC plugin 3.3.0.1,
Harmony 3 from Github,
XC32 2.3
MPLABX 5.25
 
I can create create a new project using PIC32MZ2064DAS176
 
If I open MHC 3, non of the IO config screens open and I see a few messages:
 
<Plugin>[Error]: Failed to create plugin object: "com.microchip.mh3.plugin.gpio_02467.Plugin" from file "C:\microchip\harmony\v3\csp\arch\..\peripheral\gpio_02467\plugin\gpio_02467.jar"
 
<Plugin>[Error]: Failed to create plugin object: "com.microchip.mh3.plugin.clockmanager.Plugin" from file "C:\microchip\harmony\v3\csp\arch\..\peripheral\clk_pic32mz\plugin\clockmanager.jar"
 
<Plugin>[Error]: Failed to create plugin object: "com.microchip.mh3.plugin.dmamanager.Plugin" from file "C:\microchip\harmony\v3\csp\arch\..\peripheral\dmac_01500\plugin\dmamanager.jar"
 
I tried replacing the contents of harmony\v3\csp\arch\mips\devices_pic32mz with fresh files from the Github repository.
 
Still the same problem.
 
Any idea's/help welcome
 
#1

8 Replies Related Threads

    NKurzman
    A Guy on the Net
    • Total Posts : 17939
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/09/05 07:50:25 (permalink)
    0
    Where did you can MHC? Does it match the Version of Harmony you have?
    #2
    RyanF
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2017/04/11 06:31:29
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/09/05 08:00:18 (permalink)
    0
    Hi
    I downloaded MHC3 from the plugin menu in MPLABX.
    It is the only version available in the list (3.3.0.1)
     
    I used the install Harmony 3 from the Plugin manager, it downloaded the file from Github.
     
    I would like to think that these are compatible versions as there are no other ones to select.
    #3
    optimus_jack
    Starting Member
    • Total Posts : 54
    • Reward points : 0
    • Joined: 2017/02/16 03:02:47
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/09/05 21:41:06 (permalink)
    0
    Hi,
    I just tried to create a project for PIC32MZ2064DAS176 and generate code and it worked fine. Make sure your repository tags are as below
     
    csp --> v3.4.0
    dev_packs --> v3.4.0
    mhc --> v3.3.1
    mhc_plugin --> 3.3.0.1
    #4
    NKurzman
    A Guy on the Net
    • Total Posts : 17939
    • Reward points : 0
    • Joined: 2008/01/16 19:33:48
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/09/05 23:14:31 (permalink)
    0
    I am not sure about V3. But in V1 and V2 the correct version is in the harmony folder on your drive.
    #5
    RyanF
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2017/04/11 06:31:29
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/09/06 00:52:55 (permalink)
    0
    CSP = 3.4.0
    Dev Pack = 3.4.0
    mhc = 3.3.1
     
    So all are up to date. I tried uninstalling and reinstalling the mhc, made  no difference. I have reinstalled H3, no difference.
    We are using the PIC32MZ2064DAH169 but will be moving to the PIC32MZ2064DAS169.
     
    Harmony 2 does not support the PIC32MZ2064DAS169 (problem with DDR controller temp rating has been corrected, we heed low temp DDR).
     
    All that is lest is to reinstall MPLabx, will try that.
     
    #6
    RyanF
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2017/04/11 06:31:29
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/09/06 00:54:03 (permalink)
    0
    Will also check what version is in the H3 folder
    #7
    RyanF
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2017/04/11 06:31:29
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/10/22 03:11:53 (permalink)
    0
    Hi All
     
    Getting back to this, I have re installed Harmony, disabled H2 plugin and still have the same problem:
    None of the pin configuration and clock config menu's open in MHC, I see these errors all relating to :
     
    <Plugin>[Info]: Loading plugin: C:\microchip\harmony\v3\csp\arch\..\peripheral\gpio_02467\plugin\gpio_02467.jar
    <Plugin>[Error]: Failed to create plugin object: "com.microchip.mh3.plugin.gpio_02467.Plugin" from file "C:\microchip\harmony\v3\csp\arch\..\peripheral\gpio_02467\plugin\gpio_02467.jar"

    C:\microchip\harmony\v3\csp\arch\..\peripheral\evic_02907\plugin\evic_02907.jar
    <Plugin>[Error]: Failed to create plugin object: "com.microchip.mh3.plugin.evic_02907.Plugin" from file "C:\microchip\harmony\v3\csp\arch\..\peripheral\evic_02907\plugin\evic_02907.jar"

    C:\microchip\harmony\v3\csp\arch\..\peripheral\clk_pic32mz\plugin\clockmanager.jar
    <Plugin>[Error]: Failed to create plugin object: "com.microchip.mh3.plugin.clockmanager.Plugin" from file "C:\microchip\harmony\v3\csp\arch\..\peripheral\clk_pic32mz\plugin\clockmanager.jar"

    <Plugin>[Info]: Loading plugin: C:\microchip\harmony\v3\csp\arch\..\peripheral\dmac_01500\plugin\dmamanager.jar
    <Plugin>[Error]: Failed to create plugin object: "com.microchip.mh3.plugin.dmamanager.Plugin" from file "C:\microchip\harmony\v3\csp\arch\..\peripheral\dmac_01500\plugin\dmamanager.jar"


    Any ideas's welcome
     
    #8
    RyanF
    New Member
    • Total Posts : 7
    • Reward points : 0
    • Joined: 2017/04/11 06:31:29
    • Location: 0
    • Status: offline
    Re: Harmony Configuration 3 failed to create plugin 2019/11/13 02:30:03 (permalink)
    0
    Hi All
     
    Just an update for anybody else who might have this problem.
    It turned out it was the Harmony Configurator.
    I had it in integrated mode (similar to H2 Configurator), this seems to have issues with some installations.
     
    Switching to stand alone mode, everything works as expected.
     
    Regards
     
    Ryan
    #9
    Jump to:
    © 2019 APG vNext Commercial Version 4.5