• AVR Freaks

Hot!BM64 device name

Author
howroyd
New Member
  • Total Posts : 3
  • Reward points : 0
  • Joined: 2019/07/30 08:57:30
  • Location: 0
  • Status: offline
2019/09/02 06:46:20 (permalink)
0

BM64 device name

I have the BM64 eval board and I'm trying to set either the manufacturer name or the advertising name with no luck.

0x05 works but doesn't persist after reboot.

0x2F with 0x5C sub command comes back with unknown command in the ack. Same for 0x35.

I'm working from the MS Word UART document on the website.

Unfortunately, flashing the chip using the windows tools isn't an option for my application so looking for a way of doing it over UART from the micro I have connected to it.

Setting the UUID is also an option if the name isn't possible but I've had no luck here either.

TIA
#1

1 Reply Related Threads

    howroyd
    New Member
    • Total Posts : 3
    • Reward points : 0
    • Joined: 2019/07/30 08:57:30
    • Location: 0
    • Status: offline
    Re: BM64 device name 2019/09/09 08:26:11 (permalink)
    0
    So just to add a bit more.
     
    I have flashed v2 firmware onto the BM64 and still commands 0x05, 0x2f and a few others just don't do anything. I do get an ACK, with the correct msg ID and a zero (all ok).
     
    Interestingly, using the UART tool, which handilly shows the hex of the messages it sends out, shows the same thing.  Device name change requests as above, ACKs, but nothing actually changing.
     
    I have confirmed that flashing the EEPROM does change the name, but unfortunately isn't scalable for me.
     
    Any help greatly received, please!
    #2
    Jump to:
    © 2019 APG vNext Commercial Version 4.5