• AVR Freaks

Hot!MCC can't open and gray MCC icon

Author
Oinonemm
New Member
  • Total Posts : 2
  • Reward points : 0
  • Joined: 2019/07/26 00:15:32
  • Location: 0
  • Status: offline
2019/08/19 19:31:02 (permalink)
0

MCC can't open and gray MCC icon

Please, help me
before this time I can open and config easy setting in MCC window.
Msg in MPLAB Code configurator dialog box >> INFO: Fetching list of available libraries.
and I can't close MPLABX IDE.
 
windows10
MPLAB X ver 5.2
MCC Ver 3.85.1
 
Thank you.
post edited by Oinonemm - 2019/08/21 19:18:19
#1

14 Replies Related Threads

    Jim Nickerson
    User 452
    • Total Posts : 6187
    • Reward points : 0
    • Joined: 2003/11/07 12:35:10
    • Location: San Diego, CA
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/20 10:03:52 (permalink)
    +1 (1)
    Maybe you could try unplugging the ethernet cable and or turning off the wi-fi to see if it makes any difference.
    #2
    katela
    Super Member
    • Total Posts : 1382
    • Reward points : 0
    • Joined: 2013/06/11 05:25:18
    • Location: South Africa
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/20 11:00:12 (permalink)
    0
    Or reload your project/ Restart the PC.

    Free online Microcontroller Tutorials and Projects for Hobbyists and students. From beginners to advanced. Website: www.studentcompanion.co.za
    YouTube Tutorials: https://www.youtube.com/StudentCompanionSA
    #3
    mpgmike
    Super Member
    • Total Posts : 254
    • Reward points : 0
    • Joined: 2014/01/23 17:27:06
    • Location: NJ
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/20 11:34:19 (permalink)
    0
    If you just upgraded MPLABX to a new version, you may have to reload MCC (v5.25 just came out which is why I suspect).

    I don't need the world to know my name, but I want to live a life so all my great-grandchildren proudly remember me.
    #4
    cebrax
    Starting Member
    • Total Posts : 33
    • Reward points : 0
    • Joined: 2009/10/28 07:26:53
    • Location: Turkey
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/20 21:12:24 (permalink)
    0
    I am having the exact same issue with a fresh install of the versions below:
     
    Windows 10
    MPLAB X ver 5.25
    MCC Ver 3.85.1
     
    I have leaved my PC through the night and in the morning I saw that it gave a 404 error after an hour..
    #5
    mtampelloni
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2017/12/21 01:26:12
    • Location: 0
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 02:19:38 (permalink)
    0
    I'm having the same issue with(MCC doesn't start , MCC icon gray):
    WIN10
    MCC 3.85.1
    MPLABX 5.20
    before the update to 5.20 i've never see this problem.
    i'm just trying to use MPLABX 5.20 with MCC 3.66 , i will let you know
    Marcello
    #6
    DDuck007
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/06 23:27:39
    • Location: 0
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 02:41:31 (permalink)
    0
    I have the same problem - just checking issue with Microchip.
    => Suspicion is Firmware 7.12 of Fritzbox - which router do you have?
    #7
    mtampelloni
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2017/12/21 01:26:12
    • Location: 0
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 02:54:19 (permalink)
    0
     
     
    thankyou DDuck007
    (in my case i didn't need some new features i just updeted the MCC because a new version was available)
    i have a asus DSL-AC55U ,i just finished to uinstall the 3.85.1 and the update to 3.66 ,MCC now run without problem but i'm still verifing if some driver has been corrupted by the higher MCC version.
    i will let you know
    #8
    DDuck007
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/06 23:27:39
    • Location: 0
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 03:31:00 (permalink)
    0
    Thank you - I will try 3.66 also ...
    #9
    mtampelloni
    New Member
    • Total Posts : 5
    • Reward points : 0
    • Joined: 2017/12/21 01:26:12
    • Location: 0
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 04:06:50 (permalink)
    0
    Sorry but i need to go ahead quickly and work on the project ,
    i confirm you only that 3.66 works and nothing is corrupted in the SPI,I2C ,UART and many TIMERS driver generated by the previous version and passed form 3.85.1.
    i'll wait for a newer version hoping they solve the problem using 3.66.
     
    Regards to everybody!
    #10
    DDuck007
    New Member
    • Total Posts : 9
    • Reward points : 0
    • Joined: 2018/07/06 23:27:39
    • Location: 0
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 09:14:49 (permalink)
    0
    Version 3.75 also works under MPLABX 5.25
    ... it might be a problem with 3.85.1 in combination with (some) routers ...
    #11
    katela
    Super Member
    • Total Posts : 1382
    • Reward points : 0
    • Joined: 2013/06/11 05:25:18
    • Location: South Africa
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 10:31:58 (permalink)
    0
    It might be a combination of other problems, I am currently using MPLAB X 5.25, XC8 v2.05 and MCC 3.85.1 with no problem Under windows 10 Pro 64 bit.

    Free online Microcontroller Tutorials and Projects for Hobbyists and students. From beginners to advanced. Website: www.studentcompanion.co.za
    YouTube Tutorials: https://www.youtube.com/StudentCompanionSA
    #12
    Oinonemm
    New Member
    • Total Posts : 2
    • Reward points : 0
    • Joined: 2019/07/26 00:15:32
    • Location: 0
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/21 19:16:35 (permalink)
    +1 (1)
    Hi, Jim Nickerson
    Thank a lot for your help.
    My project can open MCC when are unplugged Ethernet.
     
    And thank you everyone, every opinions.
    #13
    mpgmike
    Super Member
    • Total Posts : 254
    • Reward points : 0
    • Joined: 2014/01/23 17:27:06
    • Location: NJ
    • Status: offline
    Re: MCC can't open and MCC icon deactive 2019/08/24 05:32:42 (permalink)
    0
    Similar issue, I tried using MCC for a dsPIC33EP512MU810 project & got a message stating that PIC wasn't available in MCC.  I loaded everything Microchip's site had for it and still no love.

    I don't need the world to know my name, but I want to live a life so all my great-grandchildren proudly remember me.
    #14
    ric
    Super Member
    • Total Posts : 23581
    • Reward points : 0
    • Joined: 2003/11/07 12:41:26
    • Location: Australia, Melbourne
    • Status: online
    Re: MCC can't open and MCC icon deactive 2019/08/24 05:40:24 (permalink)
    +1 (1)
    That is a totally different issue.
    MCC only supports relatively recent chips. The dsPIC33EP512MU810 is about ten years old, so it's unlikely to ever get added to MCC.
    The release notes on the Microchip website tells you which chips it does support.
     

    I also post at: PicForum
    Links to useful PIC information: http://picforum.ric323.co...opic.php?f=59&t=15
    NEW USERS: Posting images, links and code - workaround for restrictions.
    To get a useful answer, always state which PIC you are using!
    #15
    Jump to:
    © 2019 APG vNext Commercial Version 4.5